summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-09-13 20:51:56 +0300
committerLeon Anavi <leon.anavi@konsulko.com>2019-09-13 20:57:52 +0300
commit03a470ef445dcd4707db7551cd2608e3d5166b6d (patch)
tree5ca47d66f0fc172628d9fb82019ec5c2d831d1c1 /meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
parentbad943d52c413e35879cc48a0df257f983190de8 (diff)
u-boot-2019.07: Fix for Raspberry Pi 4
Following recent changes in the BSP the recipe for u-boot 2019.07 was failing to build for Raspberry Pi 4. This fix brings existing patches from master branch of meta-raspberrypi to AGL which is still based on Yocto project release Thud. Bug-AGL: SPEC-2656 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Change-Id: Ic544d02032198dc05da24bc3246e8911d300c1ea Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
index 03e7dc849..6d89f5cb2 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
@@ -1,10 +1,10 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+# Apply the same patches for rpi4 as u-boot recipe
+require u-boot-rpi4-${PV}.inc
-SRC_URI_raspberrypi4 = "git://github.com/balena-os/u-boot;branch=ag/rpi4"
-SRCREV_raspberrypi4 = "62b6e39a53c56a9085aeab1b47b5cc6020fcdb6f"
-SRC_URI_raspberrypi4-64 = "git://github.com/balena-os/u-boot;branch=ag/rpi4"
-SRCREV_raspberrypi4-64 = "62b6e39a53c56a9085aeab1b47b5cc6020fcdb6f"
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
# Update the patch for u-boot 2019.07
SRC_URI_remove_sota = "file://0001-board-raspberrypi-add-serial-and-revision-to-the-dev.patch"
SRC_URI_append_sota = "file://0001-board-raspberrypi-add-serial-and-revision-to-the-dev-2019.07.patch"
+
+DEPENDS_append_rpi = " rpi-u-boot-scr"