summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-22 15:00:46 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-25 04:04:48 +0000
commit3acb532fd1c18c18272cc9c5c1d6530aecead700 (patch)
tree97c876dbbd1dedd4275240876412a9be4338bfff /meta-agl-bsp/meta-raspberrypi/recipes-bsp
parentb938fee8b0ab185bb036cde17537dd0ad65ab3e1 (diff)
meta-raspberrypi: AGL support for Raspberry Pi
Yocto/OE layer that extends the recipes for mesa and the supported Linux kernel for Raspberry Pi for successful build of AGL with Wayland, Weston and Qt. It is based on the existing ports of Tizen and GENIVI Development Platform for Raspberry Pi. Change-Id: Icfed9e888c2abaf26c14ab402d0a90215862afbd Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
new file mode 100644
index 000000000..871901838
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -0,0 +1,11 @@
+DISABLE_OVERSCAN = "1"
+
+do_deploy_append() {
+ echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}
+
+ENABLE_UART_raspberrypi3 = "1"