summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorAnton Gerasimov <anton@advancedtelematic.com>2016-10-31 18:09:20 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-31 22:00:54 +0000
commit9be59d935dce49e99a047b0e2f90b4d13568e7c6 (patch)
treed85fe12e845b3b45f949c4a5637acadab43555b6 /meta-agl-bsp/meta-raspberrypi/recipes-bsp
parent59bf470bc3f870791f349691c1238c0f6c5b9704 (diff)
Move RPi specific bbappends to meta-agl-bsp
Bug-AGL: SPEC-254 Change-Id: I1904b7e9ec09d5e9f5acc7a3d4671da9e2dccbb3 Signed-off-by: Anton Gerasimov <anton@advancedtelematic.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend1
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend4
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
new file mode 100644
index 000000000..88f19c6c7
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -0,0 +1 @@
+RDEPENDS_${PN}_sota += " u-boot-otascript"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 871901838..ff14d3640 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -8,4 +8,8 @@ do_deploy_append() {
echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}
+do_deploy_append_sota() {
+ echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}
+
ENABLE_UART_raspberrypi3 = "1"