summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-06-04 19:25:25 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-05 21:53:11 +0000
commitccb667c35ffdea7a2bc1304750e6b22368cd55f7 (patch)
tree8d621efea6b6500403898d1e91eed8ecbc4f093d /meta-agl-bsp/meta-raspberrypi/recipes-bsp
parenta039cce0977ca33e4532de87fd4a1867cc7b21a7 (diff)
Fix rpi touchscreen support on master
We seem to miss a few bits that changed between kernel 4.9 and kernel 4.14 regarding the 7'' touchscreen. One addition is the rpi-backlight.dtbo which we also need to use in our create-combined-dtb recipe for CI use. We also seem to require https://github.com/raspberrypi/linux/pull/2693#issue-217750943 . Thanks to Scott Murray for the help digging through this. v2 and v3: add devicetree changes v4 and v5: fix name of dtbo v6: move append to machine include - we need it as a global var v7: add to config.txt for sdcard boot case Bug-AGL: SPEC-2465 Change-Id: I2bb3cd974b74a790292e1f36ffdca034928e0bca Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend9
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend6
2 files changed, 13 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
index adb19c09c..7998c826a 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -1 +1,10 @@
RDEPENDS_${PN}_append_sota += " u-boot-otascript"
+
+# uprev firmware
+
+RPIFW_DATE = "20190517"
+SRCREV = "e1900836948f6c6bdf4571da1b966a9085c95d37"
+SRC_URI[md5sum] = "ba272fed3661f0c8d5e4c424d2617246"
+SRC_URI[sha256sum] = "2a4c566e98b16575ebf295b795b40a5772f81282948e957bdc9733cf72fdcd39"
+
+PV = "${RPIFW_DATE}"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 9222fd52a..e4246e958 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -11,8 +11,10 @@ do_deploy_append() {
echo "avoid_warnings=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "mask_gpu_interrupt0=0x400" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "dtoverlay=vc4-kms-v3d-overlay,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
- echo "dtoverlay=rpi-ft5406-overlay" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=vc4-kms-v3d,cma-256" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=rpi-7inch" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=rpi-backlight" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=rpi-ft5406" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}