summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-graphics
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-22 16:23:55 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-25 04:05:15 +0000
commit13529391207b722a73581b087550abb5fb0d0957 (patch)
tree5b772e97815659bf2032be5ed8412a5d86efa3fe /meta-agl-bsp/meta-raspberrypi/recipes-graphics
parent3acb532fd1c18c18272cc9c5c1d6530aecead700 (diff)
weston: Use drm-backend.so for Raspberry Pi
Replace weston.ini configration for Raspberry Pi and use drm-backend.so as a backend for Weston. Change-Id: I8acedd63fc0a124e4f369609270094c76b7e7f88 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini8
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend15
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
new file mode 100644
index 000000000..b491ac453
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
@@ -0,0 +1,8 @@
+[core]
+backend=drm-backend.so
+shell=desktop-shell.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..43f1da58f
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-raspberrypi.ini \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "