summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
diff options
context:
space:
mode:
authorPhong Tran <tranmanphong@gmail.com>2018-03-27 05:57:38 +0700
committerPhong Tran <tranmanphong@gmail.com>2018-04-03 21:22:23 +0700
commit4dd626c9eee962c3f86fee9e7e62b2161bca7dc6 (patch)
treee21c46a5b0f1ec766c57deb65006547e56154e0e /meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
parentea00cb6f79616987d7e3c7e83a6ee01cb73eb170 (diff)
Add hci uart ko cfg for rpi3 on board bluetooth
Enable HCI UART for fixing current lacking of hci-uart.ko which made brcm43438.service fails to start. Change-Id: I0905820daa4bc1b36f2677f2f685f17a71fe11e6 Signed-off-by: Phong Tran <tranmanphong@gmail.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index d9f843e9c..855a86257 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -28,3 +28,7 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
# Enable support for Pi foundation touchscreen
SRC_URI_append = " file://raspberrypi-panel.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
+
+# Enable bt hci uart
+SRC_URI_append = " file://raspberrypi-hciuart.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"