summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-08-07 14:05:25 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-08-13 10:10:14 +0000
commit0819413f7bb0fb035cbee42eaf5d2e56cb133db3 (patch)
tree0f410a5e2304c0aae55f18c1724cbebad04eea70 /meta-agl-bsp/meta-raspberrypi/recipes-kernel
parent852d5cc0d5ceea62ae12377c20586b552deb4e64 (diff)
meta-agl-bsp: meta-raspberrypi updates for YP 3.1.2
Changes include: - Rename bcm2835-bootfiles.bbappend to bootfiles.bbappend to match the recipe rename done in meta-raspberrypi - Update bootfile paths in rpi-config_git.bbappend to match the rename done in meta-raspberrypi - Remove local u-boot bbappend, as none of its changes are required with latest meta-raspberrypi and meta-updater - A previously silently failing command in the create-combined-dtb recipe's do_install when building with agl-sota enabled now triggers a build failure, logic has been added to handle meta-updater's disabling of the required overlay file. Bug-AGL: SPEC-3529 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ib5fd9f308fcd2da76ae882dd5b2413e56d3eee40 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25081 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
index c82e6fd22..c365715fa 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
@@ -22,7 +22,8 @@ do_compile () {
if [ -f "${DEPLOY_DIR_IMAGE}/bcm2710-rpi-3-b.dtb" ]; then
fdtoverlay -v -i ${DEPLOY_DIR_IMAGE}/bcm2710-rpi-3-b.dtb -o bcm2710-rpi-3-b+vc4+ft5406.dtb ${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo ${DEPLOY_DIR_IMAGE}/${VC4DTBO}.dtbo
fi
- if [ -f "${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb" ]; then
+ # NOTE: meta-updater currently disables rpi-ft5406.dtbo on rpi4, so need to check if it is present
+ if [ -f "${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb" -a -f "${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo" ]; then
fdtoverlay -v -i ${DEPLOY_DIR_IMAGE}/bcm2711-rpi-4-b.dtb -o bcm2711-rpi-4-b+vc4+ft5406.dtb ${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo ${DEPLOY_DIR_IMAGE}/${VC4DTBO}.dtbo
fi