summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2016-11-15 12:27:02 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-16 19:11:34 +0000
commitaea4c6d3a46dff5abb4624bd8fa3762d2abb1668 (patch)
tree0fe35ba39ff8f886af100c7634d3c40f64075847 /meta-agl-bsp/meta-raspberrypi/recipes-kernel
parentead1bded123556f3aa7d716c4e009d342b891a20 (diff)
Add support for CES 2017 demo hardware
Add kernel config fragments to enable support for the TP-Link TL-W722N USB Wifi adapter on both Turbot and Porter, and RTL2832U DVB USB adapter on Porter. v2 (jsmoeller): Adapt linux-yocto bits and add rpi3 + vayu - moving linux-yocto appends catches all the linux-yocto boards - adding the fragments to the other boards likewise - yet todo: sabre, wandboard v3 (jsmoeller): remove leftover file:// Change-Id: Ic2c3255d9383ccfe8b24d034ef43779d120c5ee1 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
index f7b12e065..9372f0a89 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
@@ -44,6 +44,16 @@ do_configure_append() {
kernel_configure_variable DRM_VC4 y
kernel_configure_variable FB_BCM2708 n
+ # Enable support for TP-Link TL-W722N USB Wifi adapter
+ kernel_configure_variable CONFIG_ATH_CARDS m
+ kernel_configure_variable CONFIG_ATH9K_HTC m
+
+ # Enable support for RTLSDR
+ kernel_configure_variable CONFIG_MEDIA_USB_SUPPORT y
+ kernel_configure_variable CONFIG_MEDIA_DIGITAL_TV_SUPPORT y
+ kernel_configure_variable CONFIG_DVB_USB_V2 m
+ kernel_configure_variable CONFIG_DVB_USB_RTL28XXU m
+
# KEEP until fixed upstream:
# Keep this the last line
# Remove all modified configs and add the rest to .config