summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi/recipes-kernel
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2016-12-28 07:45:15 +0200
committerMatt Ranostay <matt.ranostay@konsulko.com>2016-12-29 18:50:49 +0000
commitfefb358dca0ac89b970c77671b2efda2a8cf99c0 (patch)
tree05fe82058d532e491d0201eefc814561d825a85a /meta-agl-bsp/meta-raspberrypi/recipes-kernel
parentdb6bd4b3cb83a97ccde587286e16ebbaaff57d02 (diff)
linux-raspberrypi: add ENABLE_CMA options to kernel command line
Add ENABLE_CMA setting that enables required kernel configuration to allow the dynamic CMA to function. Change-Id: I0b0ab0fd7fd64454ea3cc9a89344a98897838e11 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi/recipes-kernel')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
index cc6cbeeb5..e5cdb2aff 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
@@ -66,6 +66,9 @@ do_configure_append() {
CMDLINE_DEBUG = ""
CMDLINE_append = " usbhid.mousepoll=0"
+# Add options to allow CMA to operate
+CMDLINE_append = ' ${@base_conditional("ENABLE_CMA", "1", "coherent_pool=6M smsc95xx.turbo_mode=N", "", d)}'
+
KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
KERNEL_MODULE_AUTOLOAD += "hid-multitouch"