summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-04 22:37:40 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-06-05 08:27:59 +0000
commit3d1db8e4e9260886ce761c553497589332c275cc (patch)
treed0a7c173de69fa394e188f5a74fd9362d0eba6d9 /meta-agl-bsp/meta-raspberrypi
parent72ba8aacc32ff9039a2771320792bbd161632751 (diff)
Fix orientation for dual-hdmi setup on pi4
The weston-ini-conf was not ready for dual-screen setup. Fix it. Bug-AGL: SPEC-4822 Change-Id: I75d8810fb9e58aadeceabeadf44ceedff4749d6e Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28984 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend6
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg9
2 files changed, 14 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
index 5f8af211a..9e50a75b8 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,3 +1,7 @@
FILESEXTRAPATHS:prepend:raspberrypi := "${THISDIR}/${PN}:"
-SRC_URI:append:raspberrypi = " file://dsi.cfg"
+# OLD DSI config
+#SRC_URI:append:raspberrypi = " file://dsi.cfg"
+
+# two hdmi ports
+SRC_URI:append:raspberrypi = " file://hdmi-dual.cfg"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg
new file mode 100644
index 000000000..61d1362bb
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf/hdmi-dual.cfg
@@ -0,0 +1,9 @@
+# Support the Raspberry Pi Foundation 7" tablet which uses the DSI connector
+# rather than HDMI.
+[output]
+name=HDMI-A-1
+transform=rotate-90
+
+[output]
+name=HDMI-A-2
+transform=rotate-90