summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2018-11-26 22:50:31 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-11-29 20:59:57 +0000
commit51308193e05c6c5826e312b84d2246278472a924 (patch)
tree5851ccc8e3dc646e4f9dc814b41ead010627852b /meta-agl-bsp/meta-raspberrypi
parent228b262a4b1d398ce6968c84630bab1fde31a4cf (diff)
create-combined-dtb: Add dependency on virtual/kernel
Add a dependency to virtual/kernel:do_deploy to ensure that the dtb and dtbo files needed for task compile will be present. Bug-AGL: SPEC-1775 Change-Id: I2d5872fe6bbd9a40c3f4185eea0efc10e6100b8b Reported-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
index 1323a72a2..44f90272e 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
@@ -12,6 +12,8 @@ FILES_${PN} = ""
S = "${WORKDIR}"
+do_compile[depends] += "virtual/kernel:do_deploy"
+
do_compile () {
# Official touchscreen setup (rpi3b/rpi3b dtb, vc4-kms-v3d and ft5406)
fdtoverlay -v -i ${DEPLOY_DIR_IMAGE}/uImage-bcm2710-rpi-3-b-plus.dtb -o uImage-bcm2710-rpi-3-b+vc4+ft5406.dtb ${DEPLOY_DIR_IMAGE}/rpi-ft5406.dtbo ${DEPLOY_DIR_IMAGE}/uImage-vc4-kms-v3d.dtbo