summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-09-22 16:29:09 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-26 02:03:08 +0000
commit75ee644a3344fb2f3bf5bd8733b387064c3e11f4 (patch)
treee46d80c1e3948779426e1108115d44742d1eaa94 /meta-agl-bsp/meta-raspberrypi
parent13529391207b722a73581b087550abb5fb0d0957 (diff)
weston: Set XDG_RUNTIME_DIR for Raspberry Pi
Set environment variable XDG_RUNTIME_DIR and fix Weston on Raspberry Pi 2/3 through script /etc/profile.d/weston.sh. Change-Id: Ie561623641f287e1ec911a5813c2cff225af4977 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend5
2 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
new file mode 100644
index 000000000..7d62eff77
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/var/run/user/root
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+fi
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
index 43f1da58f..7c8167961 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
@@ -2,14 +2,19 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://weston-raspberrypi.ini \
+ file://weston.sh \
"
do_install_append() {
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
install -d ${D}${WESTON_INI_CONFIG}
install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN} += " \
${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
"