summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorChanghyeok Bae <changhyeok.bae@daimler.com>2019-11-01 12:07:44 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-04 18:25:51 +0000
commitae660e0efd590d29d659e95af55b058aac5f79f9 (patch)
tree5edb9b8e1825fcfacb64b296e918dde336aaa907 /meta-agl-bsp/meta-raspberrypi
parentb7fe972ee8ac1dcdeec469c12d8bb559204a9b10 (diff)
rpi-config: Set max_framebuffers to 2 to support dual display
Change-Id: Id9ca08ede2aedbc122a04d97ca4bb5bd8478b717 Signed-off-by: Changhyeok Bae <changhyeok.bae@daimler.com>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 5c74cae7b..5eecff6f1 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -35,6 +35,11 @@ do_deploy_append() {
echo "dtparam=audio=on" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}
+do_deploy_append_raspberrypi4() {
+ echo -e "\n[pi4]" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "max_framebuffers=2" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}
+
do_deploy_append_sota() {
echo "device_tree_address=0x0c800000" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
}