summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-10-27 13:55:01 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-28 22:12:46 +0000
commitd0310f8e58504d238f629c0532e443ef7f496354 (patch)
treec50861b3f72e621204f31e3047687e51b34da92b /meta-agl-bsp/meta-raspberrypi
parent1dcaaa9e54279982b2f9794129adf0516f17c92d (diff)
Add joystick.cfg for usb joystick and steering-wheel kernel configure
Add joystick.cfg into meta-agl-bsp/recipes-kernel, Then include this cfg in each board bbappend. Related commit: https://gerrit.automotivelinux.org/gerrit/#/c/10463/ Change-Id: Ie484cc8017e7198cefa0d8e7476032c325a8348d Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11575 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Thomas Rini <trini@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 753440a3d..37066068b 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -106,3 +106,6 @@ PACKAGES += "kernel-module-snd-bcm2835"
# Enable support for usb video class for usb camera devices
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"