summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-23 15:40:17 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-24 08:30:12 +0000
commiteb11c68ae9aae60cce255a62d572bdf998a3af27 (patch)
treea64237ccb33c0f2e314ec1bcd102344265b9341c /meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
parentc30a7745a5daad19c32dbddeb46fc2ada8783325 (diff)
Fix optee-os build
* Remove the file generation and directly copy the files. the files: default_regular.c default_regular.h were generate with command line: $ scripts/render_font.py \ --font_file lib/libutee/tui/fonts/amble/Amble-Regular.ttf \ --font_size 20 --font_name default_regular \ --out_dir out/arm-plat-rcar/ta_arm64-lib/libutee/tui the files: default_bold.c default_bold.h were generate with command line: $ scripts/render_font.py \ --font_file lib/libutee/tui/fonts/amble/Amble-Bold.ttf \ --font_size 20 --font_name default_bold --out_dir out/arm-plat-rcar/ta_arm64-lib/libutee/tui python-wand 0.4.3 (and newer) is incompatible with imagemagick >= 7.0, so we need to backport imagemagick 6. If you don't have imagemagick 6 install on your host the build of optee-os will failed. Change-Id: I83a6c4b963b7d3e18f2730b601934708a2f6c7ef Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
index 591f15d84..135b2a430 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
@@ -5,4 +5,19 @@ DEPENDS += " python-pycrypto-native"
#Need for gcc 6.2
CFLAGS += " -fno-strict-aliasing -Wno-unused-variable -Wno-shift-negative-value"
+SRC_URI_append = " \
+ file://default_bold.c \
+ file://default_bold.h \
+ file://default_regular.c \
+ file://default_regular.h \
+ file://0001-Remove-the-file-generation-and-directly-copy-the-fil.patch \
+ "
+
+do_compile_prepend() {
+ GENDIRECTORY=${S}/lib/libutee/tui/fonts/amble/
+ cp ${WORKDIR}/default_bold.c ${GENDIRECTORY}
+ cp ${WORKDIR}/default_bold.h ${GENDIRECTORY}
+ cp ${WORKDIR}/default_regular.c ${GENDIRECTORY}
+ cp ${WORKDIR}/default_regular.h ${GENDIRECTORY}
+}