summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-11 15:41:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-12 10:51:11 +0000
commitf8f62f17ebbe6b63d0c8c941074bc281a31ac71c (patch)
tree447040ca1bb476c545ee55ffd2d154716a3bd51f /meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland
parent9d103eedd2535d68310b925499dcfc4a704d3291 (diff)
update weston.ini for Renesas Gen3 board
update weston.ini from Renesas rcar Gen3 BSP 2.17 Bug-AGL: SPEC-530 Change-Id: I5577a18cb5707c2484a46d3c91025ad087b6fa1e Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index de8d9552c..e46b10ef7 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1 +1,12 @@
WESTONCORE[repaint-window] ??= "34"
+
+WESTONIVISHELL[transition-duration] ??= "300"
+WESTONIVISHELL[cursor-theme] ??= "default"
+
+WESTONV4L2RENDERER[device] ??= "/dev/media0"
+WESTONV4L2RENDERER[device-module] ??= "vsp2"
+
+python() {
+ if "multimedia" in d.getVar("MACHINE_FEATURES", True).split(" "):
+ d.setVarFlag("WESTONSECTION", "WESTONV4L2RENDERER", "v4l2-renderer")
+}