summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-renesas
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2016-11-10 16:49:21 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-11 13:41:45 +0000
commit7a832073f35a54fe2db8b7045c944b4af96505e0 (patch)
treee529bc771f9be1aa7bd11d838d76e06f231a617c /meta-agl-bsp/meta-renesas
parentd4ff75ebfbed7c01fe7c91286a814316e3483df5 (diff)
meta-agl-bsp/meta-renesas: weston.ini for Reneses
Add weston.ini with preconfigured but commented out screen resolutions in the output section. Weston 1.9 with DRM backend on Renesas Porter board is known to be picky about monitors and screen resolutions. This way the developer can quickly switch to another configuration if the default fails on the current monitor. This patch should be considered as a temporary work around until there is a generic solution. Bug-AGL: SPEC-298 Change-Id: I772945a083ef4cab240c49e03c5f0cf1172a6ab2 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-renesas')
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini15
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend15
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
new file mode 100644
index 000000000..de3e7e8da
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
@@ -0,0 +1,15 @@
+[core]
+shell=desktop-shell.so
+backend=drm-backend.so
+
+[shell]
+locking=true
+# Uncomment below to hide panel
+#panel-location=none
+
+[output]
+name=HDMI-A-1
+#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
+#mode=1920x1080
+#mode=1024x768
+#transform=90
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..842c380a0
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-renesas.ini \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-renesas.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ "