summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-renesas
diff options
context:
space:
mode:
authortte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>2017-03-15 13:25:26 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-17 21:51:14 +0000
commite1a7d95053b7f19a2a7d9bf4da7625a4154c57e3 (patch)
treea26843266f3701d0a44dfaa346c879a7c4f7228b /meta-agl-bsp/meta-renesas
parent2c41fccae6bd195cb035e96f8feda9f0c73cdf1f (diff)
Add kernel config for uart bluetooth device support
Change-Id: Idb61c0f1f52ca9fb6b1afd50e4a397678971f6e5 Signed-off-by: tte_zheng_wenlong <wenlong_zheng_za@mail.toyota.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-renesas')
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend1
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg9
2 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
index 7da3e5c8a..ad297bec0 100755
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -11,6 +11,7 @@ SRC_URI += " file://disable_delay_printk.patch \
file://0001-media-r820t-do-not-double-free-fe-tuner_priv-in-r820.patch \
file://0002-media-r820t-remove-redundant-initializations-in-r820.patch \
file://0003-media-r820t-avoid-potential-memcpy-buffer-overflow-i.patch \
+ file://hciattach.cfg \
"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg ${WORKDIR}/rtl_sdr.cfg"
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg
new file mode 100755
index 000000000..95ee2d7fc
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hciattach.cfg
@@ -0,0 +1,9 @@
+CONFIG_BT_HCIUART=m
+CONFIG_BT_HCIUART_H4=y
+CONFIG_BT_HCIUART_BCSP=y
+CONFIG_BT_HCIUART_ATH3K=y
+CONFIG_BT_HCIUART_LL=y
+CONFIG_BT_HCIUART_3WIRE=y
+CONFIG_USB_SERIAL=y
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_SERIAL_CP210X=y