summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-11 11:07:56 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-11 11:07:56 -0400
commitdddd198b27bfeb90a906a1d7c29ade15920b2508 (patch)
tree27af34eb75e53aa4d11261d1e7ac3f18b69d3e31 /meta-agl-bsp/meta-ti-bsp
parentfa5152323ad2bd3d433aec72c4fec6614656f06d (diff)
meta-agl-bsp: Update Beaglebone support for Kirkstone
Changes: - Update machine template to point into new meta-ti-bsp layer in the meta-ti repository, and update the dynamic layer directory name to match. - meta-ti currently does not have Weston 10.0.0 support, and testing confirms it will not build against the currently provided version of the SGX GPU driver, so disable using it for now. - Even though the GPU driver is not being used ATM, the local patch for ti-sgx-ddk-km to handle AGL toolchain naming has been updated to ease testing meta-ti updates down the road. - The Weston bbappend that had been based on meta-arago's has been removed for now. A re-evaluation of what is needed locally will need to be done when TI have their Weston 10.0.0 support settled. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ie61cef722a643791970214710835423a21696694
Diffstat (limited to 'meta-agl-bsp/meta-ti-bsp')
-rw-r--r--meta-agl-bsp/meta-ti-bsp/.gitkeep0
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bbappend3
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch32
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km_%.bbappend3
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service19
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend18
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/mesa/mesa-gl_%.bbappend7
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_%.bbappend2
8 files changed, 84 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti-bsp/.gitkeep b/meta-agl-bsp/meta-ti-bsp/.gitkeep
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/.gitkeep
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bbappend
new file mode 100644
index 000000000..1fc5130f0
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/cm3-pm-firmware/amx3-cm3_git.bbappend
@@ -0,0 +1,3 @@
+# We need to override some of the build in defaults and the recipe is very
+# strict in how it grabs the correct compiler. Pass in our override here.
+TOOLCHAIN_OPTIONS += "${SECURITY_NOPIE_CFLAGS}"
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
new file mode 100644
index 000000000..8b59b61e2
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
@@ -0,0 +1,32 @@
+From 630046ad76e14d28bd6b0728632e4f43b0916c22 Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul.barker@sancloud.com>
+Date: Tue, 30 Nov 2021 16:48:58 +0000
+Subject: [PATCH] Add support for AGL toolchain
+
+We can use the pre-existing config for arm-linux-gnueabihf, we just need
+to make sure our toolchain is matched against this and not
+arm-linux-gnueabi.
+
+Signed-off-by: Paul Barker <paul.barker@sancloud.com>
+[Updated for 1.17.4948957/k5.10]
+Signed-off-by: Scott Murray <scott.murrary@konsulko.com>
+---
+ eurasia_km/eurasiacon/build/linux2/config/compiler.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
+index 1b5f090..6719dc2 100644
+--- a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
++++ b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
+@@ -68,7 +68,7 @@ define calculate-compiler-preferred-target
+ ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
+ $(1)_compiler_preferred_target := aarch64-linux-gnu
+ endif
+- ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-poky-linux-gnueabi arm-yoe-linux-gnueabi arm-oe-linux-musleabi arm-poky-linux-musleabi arm-yoe-linux-musleabi,$$($(1)_compiler_preferred_target)),)
++ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-poky-linux-gnueabi arm-yoe-linux-gnueabi arm-agl-linux-gnueabi arm-oe-linux-musleabi arm-poky-linux-musleabi arm-yoe-linux-musleabi,$$($(1)_compiler_preferred_target)),)
+ $(1)_compiler_preferred_target := arm-linux-gnueabihf
+ endif
+ ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
+--
+2.30.2
+
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km_%.bbappend
new file mode 100644
index 000000000..62f1947e5
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km_%.bbappend
@@ -0,0 +1,3 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-Add-support-for-AGL-toolchain.patch"
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
new file mode 100644
index 000000000..1acb94fd4
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=PVR service
+SourcePath=/etc/ti-sgx/rc.pvr
+DefaultDependencies=no
+Before=psplash-start.service
+
+[Service]
+Type=forking
+Restart=no
+TimeoutSec=5min
+IgnoreSIGPIPE=no
+KillMode=process
+GuessMainPID=no
+RemainAfterExit=yes
+ExecStart=/etc/ti-sgx/rc.pvr start
+ExecStop=/etc/ti-sgx/rc.pvr stop
+
+[Install]
+WantedBy=sysinit.target
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
new file mode 100644
index 000000000..3f497a1be
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
+FILES:${PN} += "/etc/ti-sgx/"
+
+SRC_URI:append = "\
+ file://pvr.service \
+"
+
+inherit systemd
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "pvr.service"
+
+do_install:append() {
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
+ install -d ${D}/etc/ti-sgx
+ install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
+}
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/mesa/mesa-gl_%.bbappend
new file mode 100644
index 000000000..d12ab2be2
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -0,0 +1,7 @@
+# Remove GBM support from Mesa
+# TI Platforms provides own GBM library
+
+PACKAGES:remove = "libgbm"
+PACKAGES:remove = "libgbm-dev"
+
+EXTRA_OECONF:remove = "--enable-gbm"
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_%.bbappend
new file mode 100644
index 000000000..07ba7d4d1
--- /dev/null
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -0,0 +1,2 @@
+require recipes-kernel/linux/linux-agl-config.inc
+