summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-03-30 13:42:50 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-04 08:49:07 +0000
commite5647d8e3da999c353a48c139c9a968705c5a891 (patch)
tree42cdea20ccabfddf5bb836913a32da04572edc1e /meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
parent8b721aa4ae997a5e18d97d5125038f1cd4640949 (diff)
dra7xx: gstreamer1.0-plugins-bad: Upgrade to 1.8.2
Apart from upgrading to 1.8.2 as the base, it also contains several TI specific patches that are required to enable functionality for kmssink and waylandsink. A few bug fixes have also been included in this patch set. This recipe is rehosted from meta-arago Change-Id: I2a5b95db1b0e6b2b907f3e82ff738fd8124c0998 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 000000000..53cd834aa
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,49 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PACKAGECONFIG = "faad"
+
+# gstreamer is now also included on Keystone, be mindful of any Graphics dependencies
+PACKAGECONFIG_append_omap-a15 = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
+PACKAGECONFIG_append_ti43x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
+PACKAGECONFIG_append_ti33x = " ${@bb.utils.contains('DISTRO_FEATURES','wayland','wayland','',d)}"
+
+DEPENDS_append_omap-a15 = " \
+ libdrm \
+"
+
+DEPENDS_append_ti43x = " \
+ libdrm \
+"
+
+DEPENDS_append_ti33x = " \
+ libdrm \
+"
+
+SRC_URI_append_ti43x = " \
+ file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
+ file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
+ file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
+ file://0004-gstwaylandsink-Add-DRM-support-on-waylandsink.patch \
+ file://0002-kmssink-remove-DCE-dependencies.patch \
+ file://0003-kmssink-add-YUYV-support.patch \
+ file://0001-gstwaylandsink-add-input-format-I420-support.patch \
+"
+
+SRC_URI_append_ti33x = " \
+ file://0001-gstwaylandsink-Add-mouse-drag-and-drop-support.patch \
+"
+
+SRC_URI_append_omap-a15 = " \
+ file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
+ file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
+ file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
+ file://0004-gstwaylandsink-Add-DRM-support-on-waylandsink.patch \
+ file://0002-kmssink-remove-DCE-dependencies.patch \
+ file://0003-kmssink-add-YUYV-support.patch \
+ file://0001-gstwaylandsink-add-input-format-I420-support.patch \
+ file://0005-gstwaylandsink-Implement-callbacks-for-version-5-of-.patch \
+"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+PR = "r4"