summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-03-23 15:32:00 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-28 10:00:18 +0000
commit0916ed9046abb78e4d270a57d59606569cf43749 (patch)
treec2c588652fa90ffb62d9b47e2da0b5e9fce4c7e0 /meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch
parent7480d16c667a773f6762a15934c4e617b0731f72 (diff)
dra7xx: weston: add patches for weston 1.11
These patches are rehosted from meta-arago Reference: https://goo.gl/889cIi Change-Id: I888303ddd99a431587ebb4f7ed5f0f90a6e6538d Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch
index 751a7cee9..4268b7dc2 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-Add-soc-performance-monitor-utilites.patch
@@ -7,7 +7,7 @@ Signed-off-by: Karthik Ramanan <a0393906@ti.com>
---
Makefile.am | 17 +-
clients/Dra7xx_ddrstat_speed.c | 494 +++++++++++++
- clients/soc_performance_monitor.c | 625 ++++++++++++++++
+ clients/soc_performance_monitor.c | 630 ++++++++++++++++
clients/soc_performance_monitor.h | 40 ++
clients/statcoll.c | 1433 +++++++++++++++++++++++++++++++++++++
clients/statcoll.h | 152 ++++
@@ -564,7 +564,7 @@ new file mode 100644
index 0000000..5d1db32
--- /dev/null
+++ b/clients/soc_performance_monitor.c
-@@ -0,0 +1,625 @@
+@@ -0,0 +1,630 @@
+/*
+ * Copyright (C) 2016 Texas Instruments
+ * Author: Karthik Ramanan <karthik.ramanan@ti.com>
@@ -666,9 +666,14 @@ index 0000000..5d1db32
+
+ for(i=cpu_load_offset; i<cpu_load_offset+total_cpu_load_items; i++) {
+ if(strcmp(text[i*2], field) == 0) {
-+ y[i*2+1] = atoi(value)/100.0;
-+ sprintf(text[i*2+1], " %02s%s", value,"%");
-+ printd("CPULOAD: Updating %s with %s\n", field, value);
++ if(strlen(value) <= 2) {
++ y[i*2+1] = atoi(value)/100.0;
++ sprintf(text[i*2+1], " %02s%s", value,"%");
++ printd("CPULOAD: Updating %s with %s\n", field, value);
++ }
++ else {
++ printf("Ignoring value: %s\n", value);
++ }
+ }
+ }
+ }