summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-02-06 16:09:39 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-02-07 15:12:40 +0000
commit5e3de49a057a7b65ee214552f4584421af29e792 (patch)
treed3e70a5739bc5e1306a179a254c6873e832166e0 /meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
parentdadfe6cb9aa0a06175d3bd59ac59b51824d6f76f (diff)
meta-agl-bsp/meta-arago: update weston bbappend
Update weston bbappend orginally from meta-arago/meta-arago-distro to work with zeus. The new weston_7.0.0.bbappend is based on the version from meta-arago's zeus branch as of commit 9646a5e, with some edits to remove unneeded patches after discussion with the meta-ti / meta-arago maintainer. Bug-AGL: SPEC-2932 Change-Id: Ia0a719b1fc7ed2f31c40a2b491cfc5e4b0f71cd0 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
new file mode 100644
index 000000000..32901db99
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch
@@ -0,0 +1,41 @@
+From 8034bc1862bbebb332e91917c6458ef8efb5b54e Mon Sep 17 00:00:00 2001
+From: Eric Ruei <e-ruei1@ti.com>
+Date: Fri, 8 Mar 2019 18:49:07 -0500
+Subject: [PATCH] weston: Fix virtual keyboard display issue for QT5
+ application
+
+The virtual keyboard does pop up as expected, however, it will never hide
+even when the application is terminated. This problem is due to the order
+of the text APIs( text_input_activate and test_input_show_input_panel) are
+invoked in QT5 and a potential bug of the API implementation. The virtual
+keyboard works as expected if the test_input_show_input_panel() is invoked
+prior to the test_input_activate() as most of the weston sample applications
+do. However, the problem will show up if that order is reversed and the reason
+why is that the current_panel is not set in this case and hence this panel
+cannot be hidden.
+
+It is required to set the current_panel to the text_input when the input_panel
+becomes visible at the first time.
+
+Upstream status: Pending
+
+Signed-off-by: Eric Ruei <e-ruei1@ti.com>
+---
+ compositor/text-backend.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/compositor/text-backend.c b/compositor/text-backend.c
+index 664c36f..b610dfb 100644
+--- a/compositor/text-backend.c
++++ b/compositor/text-backend.c
+@@ -349,6 +349,7 @@ text_input_show_input_panel(struct wl_client *client,
+ text_input->surface);
+ wl_signal_emit(&ec->update_input_panel_signal,
+ &text_input->cursor_rectangle);
++ text_input->manager->current_text_input = text_input;
+ }
+ }
+
+--
+1.9.1
+