summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-11 11:07:56 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-11 11:07:56 -0400
commitdddd198b27bfeb90a906a1d7c29ade15920b2508 (patch)
tree27af34eb75e53aa4d11261d1e7ac3f18b69d3e31 /meta-agl-bsp/meta-ti/recipes-graphics
parentfa5152323ad2bd3d433aec72c4fec6614656f06d (diff)
meta-agl-bsp: Update Beaglebone support for Kirkstone
Changes: - Update machine template to point into new meta-ti-bsp layer in the meta-ti repository, and update the dynamic layer directory name to match. - meta-ti currently does not have Weston 10.0.0 support, and testing confirms it will not build against the currently provided version of the SGX GPU driver, so disable using it for now. - Even though the GPU driver is not being used ATM, the local patch for ti-sgx-ddk-km to handle AGL toolchain naming has been updated to ease testing meta-ti updates down the road. - The Weston bbappend that had been based on meta-arago's has been removed for now. A re-evaluation of what is needed locally will need to be done when TI have their Weston 10.0.0 support settled. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ie61cef722a643791970214710835423a21696694
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service19
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend18
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend7
3 files changed, 0 insertions, 44 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
deleted file mode 100644
index 1acb94fd4..000000000
--- a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um/pvr.service
+++ /dev/null
@@ -1,19 +0,0 @@
-[Unit]
-Description=PVR service
-SourcePath=/etc/ti-sgx/rc.pvr
-DefaultDependencies=no
-Before=psplash-start.service
-
-[Service]
-Type=forking
-Restart=no
-TimeoutSec=5min
-IgnoreSIGPIPE=no
-KillMode=process
-GuessMainPID=no
-RemainAfterExit=yes
-ExecStart=/etc/ti-sgx/rc.pvr start
-ExecStop=/etc/ti-sgx/rc.pvr stop
-
-[Install]
-WantedBy=sysinit.target
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
deleted file mode 100644
index 3f497a1be..000000000
--- a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
+++ /dev/null
@@ -1,18 +0,0 @@
-FILESEXTRAPATHS:append := ":${THISDIR}/${PN}"
-FILES:${PN} += "/etc/ti-sgx/"
-
-SRC_URI:append = "\
- file://pvr.service \
-"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE:${PN} = "pvr.service"
-
-do_install:append() {
- install -d ${D}${systemd_system_unitdir}
- install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
- install -d ${D}/etc/ti-sgx
- install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
-}
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend
deleted file mode 100644
index d12ab2be2..000000000
--- a/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-# Remove GBM support from Mesa
-# TI Platforms provides own GBM library
-
-PACKAGES:remove = "libgbm"
-PACKAGES:remove = "libgbm-dev"
-
-EXTRA_OECONF:remove = "--enable-gbm"