summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-03-29 13:44:05 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-30 07:28:27 +0000
commit1a87a64ed73e045c9c69321f9deb104f570bc720 (patch)
tree1d84aa82026d495469f26f104c2d0c8b64e9b885 /meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
parent6045050bc66c8aa99aa12aa0404cd6d8543eafa5 (diff)
dra7xx: linux: rename kernel recipe to make version agnostic
Change-Id: Id33c8f4c1d75aa6adf1b276995fc7991603c41cb Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
new file mode 100644
index 000000000..11063ab1d
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
@@ -0,0 +1,38 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append = " file://ramblock_nbd.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ramblock_nbd.cfg"
+
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI_append = " file://ath9k_htc.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg"
+
+# Enable support for RTLSDR
+SRC_URI_append = " file://rtl_sdr.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/rtl_sdr.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/btusb.cfg"
+
+SRCREV = "${AUTOREV}"
+
+PV = "4.4.31+git${SRCPV}"
+
+KERNEL_GIT_URI = "git://git.omapzoom.org/kernel/omap"
+BRANCH = "p-ti-lsk-linux-4.4.y-next"
+SRC_URI_append = " \
+ "
+
+KERNEL_DEVICETREE_dra7xx-evm_append = " dra7-evm-vision.dtb dra72-evm-vision.dtb am57xx-evm.dtb"
+
+#-------------------------------------------------------------------------
+# smack patches for handling bluetooth
+
+SRC_URI_append_smack = "\
+ file://0001-Smack-File-receive-for-sockets.patch \
+ file://0002-smack-fix-cache-of-access-labels.patch \
+ file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
+ file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
+"
+