summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2017-03-23 15:53:05 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-29 16:16:23 +0000
commit189a4e97b2d7cd294b50f3bc90be41349b6fe215 (patch)
treec2b73f936047eba8c1c38b6ff0e12bf9bd3cf822 /meta-agl-bsp/meta-ti
parentfa3a10cc6a4006180269d8d3402fa9941ab9748f (diff)
dra7xx: weston: cleanup patches
Change-Id: Ia2f246daae241a4b91721b7c17ae608145cd30a3 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp/meta-ti')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston-Enabling-DRM-backend-with-multiple-displays.patch60
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston1.9.0-Enabling-DRM-backend-with-multiple-displ.patch60
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0002-Weston1.9.0-Allow-visual_id-to-be-0.patch31
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-Weston1.9.0-Fix-virtual-keyboard-display-issue-for-Q.patch40
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0004-Weston1.9.0-Fix-touch-screen-crash-issue.patch37
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend2
6 files changed, 1 insertions, 229 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston-Enabling-DRM-backend-with-multiple-displays.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston-Enabling-DRM-backend-with-multiple-displays.patch
deleted file mode 100644
index 2f215c9f0..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston-Enabling-DRM-backend-with-multiple-displays.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From b1829ce962aa4e13d737edb54130bdce05f068f0 Mon Sep 17 00:00:00 2001
-From: Karthik Ramanan <a0393906@ti.com>
-Date: Wed, 17 Dec 2014 09:21:49 +0530
-Subject: [PATCH] weston: Enabling DRM backend with multiple displays
-
-There are three main issues that this patch tries to address
-
- 1. Black screen when running weston
- 2. Support for multiple displays
- 3. Handling missing VBlanks
-
-There is an issue with missing VBlanks for LCD and
-HDMI connectors which leads to display not getting refreshed.
-This patch can be considered as a workaround.
-
-Signed-off-by: Karthik Ramanan <a0393906@ti.com>
----
- src/compositor-drm.c | 10 ++++++++--
- 1 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/src/compositor-drm.c b/src/compositor-drm.c
-index e4496e7..3b22aa3 100644
---- a/src/compositor-drm.c
-+++ b/src/compositor-drm.c
-@@ -646,7 +646,7 @@ drm_output_repaint(struct weston_output *output_base,
- .request.sequence = 1,
- };
-
-- if ((!s->current && !s->next) ||
-+ if ((!s->current && !s->next) &&
- !drm_sprite_crtc_supported(output_base, s->possible_crtcs))
- continue;
-
-@@ -757,6 +757,7 @@ page_flip_handler(int fd, unsigned int frame,
- {
- struct drm_output *output = (struct drm_output *) data;
- uint32_t msecs;
-+ uint32_t bail;
-
- /* We don't set page_flip_pending on start_repaint_loop, in that case
- * we just want to page flip to the current buffer to get an accurate
-@@ -769,9 +770,14 @@ page_flip_handler(int fd, unsigned int frame,
-
- output->page_flip_pending = 0;
-
-+ if(output->vblank_pending) {
-+ weston_log("VBlank is pending for connector = %d, frame = %d\n", output->connector_id, frame);
-+ bail = 1;
-+ }
-+
- if (output->destroy_pending)
- drm_output_destroy(&output->base);
-- else if (!output->vblank_pending) {
-+ else if (!output->vblank_pending || bail ) {
- msecs = sec * 1000 + usec / 1000;
- weston_output_finish_frame(&output->base, msecs);
-
---
-1.7.9.5
-
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston1.9.0-Enabling-DRM-backend-with-multiple-displ.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston1.9.0-Enabling-DRM-backend-with-multiple-displ.patch
deleted file mode 100644
index 3efceb5db..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-weston1.9.0-Enabling-DRM-backend-with-multiple-displ.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 15d9f155fdb3abffc348e81b1560702801994715 Mon Sep 17 00:00:00 2001
-From: Karthik Ramanan <a0393906@ti.com>
-Date: Mon, 11 Jan 2016 11:51:30 -0500
-Subject: [PATCH 1/2] weston1.9.0: Enabling DRM backend with multiple displays
-
-There are three main issues that this patch tries to address
-
- 1. Black screen when running weston
- 2. Support for multiple displays
- 3. Handling missing VBlanks
-
-There is an issue with missing VBlanks for LCD and
-HDMI connectors which leads to display not getting refreshed.
-This patch can be considered as a workaround.
-
-Signed-off-by: Karthik Ramanan <a0393906@ti.com>
----
- src/compositor-drm.c | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/src/compositor-drm.c b/src/compositor-drm.c
-index 6777bf8..15ddba8 100644
---- a/src/compositor-drm.c
-+++ b/src/compositor-drm.c
-@@ -686,7 +686,7 @@ drm_output_repaint(struct weston_output *output_base,
- .request.sequence = 1,
- };
-
-- if ((!s->current && !s->next) ||
-+ if ((!s->current && !s->next) &&
- !drm_sprite_crtc_supported(output, s->possible_crtcs))
- continue;
-
-@@ -847,6 +847,7 @@ page_flip_handler(int fd, unsigned int frame,
- {
- struct drm_output *output = (struct drm_output *) data;
- struct timespec ts;
-+ uint32_t bail;
- uint32_t flags = PRESENTATION_FEEDBACK_KIND_VSYNC |
- PRESENTATION_FEEDBACK_KIND_HW_COMPLETION |
- PRESENTATION_FEEDBACK_KIND_HW_CLOCK;
-@@ -864,9 +865,14 @@ page_flip_handler(int fd, unsigned int frame,
-
- output->page_flip_pending = 0;
-
-+ if(output->vblank_pending) {
-+ weston_log("VBlank is pending for connector = %d, frame = %d\n", output->connector_id, frame);
-+ bail = 1;
-+ }
-+
- if (output->destroy_pending)
- drm_output_destroy(&output->base);
-- else if (!output->vblank_pending) {
-+ else if (!output->vblank_pending || bail ) {
- ts.tv_sec = sec;
- ts.tv_nsec = usec * 1000;
- weston_output_finish_frame(&output->base, &ts, flags);
---
-1.9.1
-
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0002-Weston1.9.0-Allow-visual_id-to-be-0.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0002-Weston1.9.0-Allow-visual_id-to-be-0.patch
deleted file mode 100644
index 72d067fd9..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0002-Weston1.9.0-Allow-visual_id-to-be-0.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 27cf7d0c260fa4754a021e9f6f92f83e2c99f5f4 Mon Sep 17 00:00:00 2001
-From: Eric Ruei <e-ruei1@ti.com>
-Date: Mon, 11 Jan 2016 11:59:19 -0500
-Subject: [PATCH 2/2] Weston1.9.0: Allow visual_id to be 0
-
-The inquiry of visual id from egl API eglGetConfigAttrib(EGL_NATIVE_VISUAL_ID)
-is an optional feature. The visual id will be set to 0 if this feature is
-not supported. Therefore, the return condition @function match_config_to_visual()
-should be (id == visual_id || id == 0) instead of (id == visual_id)
-
-Signed-off-by: Eric Ruei <e-ruei1@ti.com>
----
- src/gl-renderer.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gl-renderer.c b/src/gl-renderer.c
-index d7231f4..e1b925e 100644
---- a/src/gl-renderer.c
-+++ b/src/gl-renderer.c
-@@ -2194,7 +2194,7 @@ match_config_to_visual(EGLDisplay egl_display,
- &id))
- continue;
-
-- if (id == visual_id)
-+ if (id == visual_id || id == 0)
- return i;
- }
-
---
-1.9.1
-
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-Weston1.9.0-Fix-virtual-keyboard-display-issue-for-Q.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-Weston1.9.0-Fix-virtual-keyboard-display-issue-for-Q.patch
deleted file mode 100644
index 576b37e15..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0003-Weston1.9.0-Fix-virtual-keyboard-display-issue-for-Q.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 7d2f4a97306707fb29e743bf66a827e661aa5615 Mon Sep 17 00:00:00 2001
-From: Eric Ruei <e-ruei1@ti.com>
-Date: Tue, 23 Feb 2016 18:26:57 -0500
-Subject: [PATCH 3/3] Weston1.9.0: Fix virtual keyboard display issue for QT5
- application
-
-The virtual keyboard does pop up as expected, however, it will never hide
-even when the application is terminated. This problem is due to the order
-of the text APIs( text_input_activate and test_input_show_input_panel) are
-invoked in QT5 and a potential bug of the API implementation. The virtual
-keyboard works as expected if the test_input_show_input_panel() is invoked
-prior to the test_input_activate() as most of the weston sample applications
-do. However, the problem will show up if that order is reversed and the reason
-why is that the current_panel is not set in this case and hence this panel
-cannot be hidden.
-
-It is required to set the current_panel to the text_input when the input_panel
-becomes visible at the first time.
-
-
-Signed-off-by: Eric Ruei <e-ruei1@ti.com>
----
- src/text-backend.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/text-backend.c b/src/text-backend.c
-index cd6c4d99..ba60949 100644
---- a/src/text-backend.c
-+++ b/src/text-backend.c
-@@ -338,6 +338,7 @@ text_input_show_input_panel(struct wl_client *client,
- text_input->surface);
- wl_signal_emit(&ec->update_input_panel_signal,
- &text_input->cursor_rectangle);
-+ text_input->manager->current_panel = text_input;
- }
- }
-
---
-1.9.1
-
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0004-Weston1.9.0-Fix-touch-screen-crash-issue.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0004-Weston1.9.0-Fix-touch-screen-crash-issue.patch
deleted file mode 100644
index c221d1c5e..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0004-Weston1.9.0-Fix-touch-screen-crash-issue.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 9a7c0e7b6ae9700069756b33d2ea726e58b552ed Mon Sep 17 00:00:00 2001
-From: Eric Ruei <e-ruei1@ti.com>
-Date: Wed, 16 Mar 2016 16:50:31 -0400
-Subject: [PATCH 4/4] Weston1.9.0: Fix touch screen crash issue
-
-Touch screen operation causes the weston to crash with segment fault sometimes.
-The crash occurs when the coordinate (x,y) passed to the weston input module
-is outside the view window, hence the weston compositor is not able to pick
-up a display view and there is no code to detect this condition at function
-notify_touch().
-
-
-Signed-off-by: Eric Ruei <e-ruei1@ti.com>
----
- src/input.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/input.c b/src/input.c
-index e230c83..fd8e53f 100644
---- a/src/input.c
-+++ b/src/input.c
-@@ -1566,6 +1566,12 @@ notify_touch(struct weston_seat *seat, uint32_t time, int touch_id,
- * until all touch points are up again. */
- if (touch->num_tp == 1) {
- ev = weston_compositor_pick_view(ec, x, y, &sx, &sy);
-+ if (!ev)
-+ {
-+ weston_log("notify_touch: weston_compositor_pick_view(%d, %d) failed to find a view!\n",
-+ wl_fixed_to_int(x), wl_fixed_to_int(y));
-+ return;
-+ }
- weston_touch_set_focus(touch, ev);
- } else if (!touch->focus) {
- /* Unexpected condition: We have non-initial touch but
---
-1.9.1
-
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
index 5f22fccab..ed20c7420 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
@@ -2,7 +2,7 @@
PACKAGECONFIG[fbdev] = "--enable-fbdev-compositor WESTON_NATIVE_BACKEND="fbdev-backend.so",--disable-fbdev-compositor,udev mtdev"
PACKAGECONFIG[kms] = "--enable-drm-compositor,--disable-drm-compositor,drm udev libgbm mtdev"
-PR_append = ".agl_arago22"
+PR_append = ".agl_arago_23"
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"