summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2017-09-16 17:32:30 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-17 17:49:14 +0000
commit3d6217e8d41dee73fe79e9f8dd5fa1b53ff06da0 (patch)
tree4c6d105c9d94230c45751feb844beeb8943e0b0a /meta-agl-bsp/meta-ti
parent6ab757860c20d1777e5a7fed7938473ec671280c (diff)
Fix rpm metadata clash due to change of rpm backend
The rpm backend used in pyro changed behaviour and if multiple packages 'own' a directory the installation will fail. Inject a flag to mitigate this and avoid the break. Conflicting packages libgbm-dev and ti-sgx-ddk-um-dev on /usr/lib/pkgconfig . Change-Id: I52439d94c230a9314a543e00edd247f29d10e113 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10927 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl-bsp/meta-ti')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/gbm/libgbm_%.bbappend2
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend4
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/gbm/libgbm_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/gbm/libgbm_%.bbappend
new file mode 100644
index 000000000..7a16fbfe6
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/gbm/libgbm_%.bbappend
@@ -0,0 +1,2 @@
+# Hotfix for rpm metadata clash with ti-sgx-ddk-um-dev
+DIRFILES = "1"
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
index 21142df59..fe93f1a6b 100644
--- a/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
@@ -16,3 +16,7 @@ do_install_append() {
install -d ${D}/etc/ti-sgx
install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
}
+
+
+# Fix for rpm metadata clash with libgbm-dev
+DIRFILES = "1"