summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-21 13:22:11 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-05-29 14:48:50 +0200
commita13476b9df4b7ac92a6e29e42025e7184ce035f6 (patch)
tree6bf5ddff6302a936a52bf6a9ebbeec8f11c8bd4c /meta-agl-bsp/meta-ti
parent8001f0ebbec73f4b364d4b99aa42646948b5c40f (diff)
Add weston 6.0.0 for WM and HS rewrite
As requested for the WM and HS rewrite. Tested on m3, minnow, qemux86-64, rpi3. (cherry picked from commit fda5568cf4bc268088c9d1f925007d682bb7ef5d) Multiple commits to applied at once. Bug-AGL: SPEC-2444 Change-Id: I3f74b40213d4c4a65400a53fe9c57f52fe3b6096 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-ti')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-FIX-weston-clients-typo-in-simple-dmabuf-egl.c.patch29
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend2
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-FIX-weston-clients-typo-in-simple-dmabuf-egl.c.patch b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-FIX-weston-clients-typo-in-simple-dmabuf-egl.c.patch
new file mode 100644
index 000000000..7801bdd57
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/0001-FIX-weston-clients-typo-in-simple-dmabuf-egl.c.patch
@@ -0,0 +1,29 @@
+From 53d7c243ba0baa052081735b8effff4e2679ce65 Mon Sep 17 00:00:00 2001
+From: Kamal Pandey <kamal.pandey@ifm.com>
+Date: Thu, 4 Apr 2019 19:45:45 +0530
+Subject: [PATCH] FIX: weston: clients: typo in simple-dmabuf-egl.c
+
+Fix variable EGL_NO_IMAGE to EGL_NO_IMAGE_KHR in
+clients/simple-dmabuf-egl.c
+
+Signed-off-by: Kamal Pandey <pandeykamal13526@gmail.com>
+---
+ clients/simple-dmabuf-egl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/clients/simple-dmabuf-egl.c b/clients/simple-dmabuf-egl.c
+index 75d880e08..2d99c4709 100644
+--- a/clients/simple-dmabuf-egl.c
++++ b/clients/simple-dmabuf-egl.c
+@@ -293,7 +293,7 @@ create_fbo_for_buffer(struct display *display, struct buffer *buffer)
+ EGL_NO_CONTEXT,
+ EGL_LINUX_DMA_BUF_EXT,
+ NULL, attribs);
+- if (buffer->egl_image == EGL_NO_IMAGE) {
++ if (buffer->egl_image == EGL_NO_IMAGE_KHR) {
+ fprintf(stderr, "EGLImageKHR creation failed\n");
+ return false;
+ }
+--
+2.21.0
+
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
index 2005b601e..5d27bb8ed 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
@@ -15,7 +15,7 @@ DISABLED_SRC_URI += " \
####################### F I X M E ##########################
SRC_URI += " \
- file://0001-udev-seat-restrict-udev-enumeration-to-card0.patch \
+ file://0001-FIX-weston-clients-typo-in-simple-dmabuf-egl.c.patch \
file://0002-Weston-Allow-visual_id-to-be-0.patch \
file://0003-Weston-Fix-virtual-keyboard-display-issue-for-QT5-ap.patch \
file://0004-Weston-Fix-touch-screen-crash-issue.patch \