summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-01 02:21:58 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-02 19:05:17 +0200
commit1f7c63cb0f2d85325d7dcc7b49cd3038e395b42a (patch)
treeea8f6e1a6a88f8338008dcd19cc7bb4055e57535 /meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
parent3fb78c5ff1b63c5c4703efde2dc405d897fda74c (diff)
Cleanup of recipes - part 2
- meta-core is a duplication, move right into meta-agl-bsp/recipes-* - u-boot-otascript is now part of meta-updater-raspberrypi - u-boot-ota_2015.07 is replaced with meta-updater-qemux86-64 - opencv is now in meta-oe - move virtualization-layer to 'meta-virtualization-layer' for consistency all dynamic included layers start with 'meta-' Bug-AGL: SPEC-3468 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Id56f1b60757b304c29ba7a8e11934a6dbf56f129
Diffstat (limited to 'meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb')
-rw-r--r--meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb b/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
new file mode 100644
index 000000000..ae8fe71b6
--- /dev/null
+++ b/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen-mkimage-rpi4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Xen hypervisor u-boot image"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+
+
+ALLOW_EMPTY_${PN} = "1"
+FILES_${PN} = ""
+S = "${WORKDIR}"
+
+DEPENDS = "u-boot-mkimage-native "
+
+# Only for aarch64
+COMPATIBLE_MACHINE = "(-)"
+COMPATIBLE_MACHINE_aarch64 = "(.*)"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_deploy[noexec] = "1"
+
+do_compile[depends] += "xen:do_deploy"
+
+# Uboot compatible image
+do_compile () {
+ uboot-mkimage -A arm64 -C none -T kernel -a 0x48080000 -e 0x48080000 -n "XEN" -d ${DEPLOY_DIR_IMAGE}/xen-${MACHINE} ${DEPLOY_DIR_IMAGE}/xen-${MACHINE}.uImage
+}