summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-01 02:21:58 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-02 19:05:17 +0200
commit1f7c63cb0f2d85325d7dcc7b49cd3038e395b42a (patch)
treeea8f6e1a6a88f8338008dcd19cc7bb4055e57535 /meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend
parent3fb78c5ff1b63c5c4703efde2dc405d897fda74c (diff)
Cleanup of recipes - part 2
- meta-core is a duplication, move right into meta-agl-bsp/recipes-* - u-boot-otascript is now part of meta-updater-raspberrypi - u-boot-ota_2015.07 is replaced with meta-updater-qemux86-64 - opencv is now in meta-oe - move virtualization-layer to 'meta-virtualization-layer' for consistency all dynamic included layers start with 'meta-' Bug-AGL: SPEC-3468 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Id56f1b60757b304c29ba7a8e11934a6dbf56f129
Diffstat (limited to 'meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend')
-rw-r--r--meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend b/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend
new file mode 100644
index 000000000..1b9aaf4ca
--- /dev/null
+++ b/meta-agl-bsp/meta-virtualization-layer/recipes-extended/xen/xen_git.bbappend
@@ -0,0 +1,18 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# make the package machine-specific
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+# rpi4 specifics
+LIC_FILES_CHKSUM_raspberrypi4 = "file://COPYING;md5=4295d895d4b5ce9d070263d52f030e49"
+XEN_REL_raspberrypi4 = "4.13"
+
+SRCREV_raspberrypi4 = "721f2c323ca55c77857c93e7275b4a93a0e15e1f"
+SRC_URI_append_raspberrypi4 = " file://0001-XEN-on-RPi4-1GB-lmitation-workaround-XEN-tries-to-al.patch"
+
+#due to incorrect xen binary preparation in external library, we add additional deploy
+do_deploy_append_raspberrypi4() {
+ if [ -f ${B}/xen/xen ]; then
+ install -m 0644 ${B}/xen/xen ${DEPLOYDIR}/xen-${MACHINE}
+ fi
+}