summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-bsp
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-04-14 00:32:42 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-05-01 21:38:46 +0000
commitf431a64246282e068570519b137cc8670521addd (patch)
tree58ffdafc104a7129d1185a133d4541e0097607a6 /meta-agl-bsp/recipes-bsp
parent7e1ebd1b2588503d8e2216cee5e7db7d0c70df83 (diff)
Introduce TI DRA7 vayu and cleanup template files
This changeset introduces the TI 'vayu' board. We need to adapt the provided bsp layer 'meta-ti' as it is only at YP 1.8 fido right now. Two changes are needed/known: a) BBMASK eudev bbappend (local.conf.sample) b) apply patch for gcc5 to u-boot-ti-staging On top thie changeset also does janitorial work on the templates: - conf-notes is now in a folder common and symlinked - layer additions have been sync'ed - file layout sync'ed with templates in meta-agl-demo Change-Id: Ib52a9252800d54d5105ac1f5354ad3a3b014188f Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/recipes-bsp')
-rw-r--r--meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch26
-rw-r--r--meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend4
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch b/meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch
new file mode 100644
index 000000000..c462191ae
--- /dev/null
+++ b/meta-agl-bsp/recipes-bsp/u-boot/files/fix_builderror_gcc5.patch
@@ -0,0 +1,26 @@
+Fix the following build break:
+
+drivers/usb/host/xhci-omap.c:35:5: error: ‘board_usb_init’ aliased to external symbol ‘__board_usb_init’
+ int board_usb_init(int index, enum usb_init_type init)
+ ^
+
+Signed-off-by: Felipe Balbi <balbi at ti.com>
+---
+ drivers/usb/host/xhci-omap.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/drivers/usb/host/xhci-omap.c b/drivers/usb/host/xhci-omap.c
+index 104e7a7282cf..fd19f79f0fc5 100644
+--- a/drivers/usb/host/xhci-omap.c
++++ b/drivers/usb/host/xhci-omap.c
+@@ -27,7 +27,7 @@ DECLARE_GLOBAL_DATA_PTR;
+
+ static struct omap_xhci omap;
+
+-inline int __board_usb_init(int index, enum usb_init_type init)
++__weak int __board_usb_init(int index, enum usb_init_type init)
+ {
+ return 0;
+ }
+--
+2.5.3 \ No newline at end of file
diff --git a/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend b/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend
new file mode 100644
index 000000000..50050ab6b
--- /dev/null
+++ b/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2015.07.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
+SRC_URI_vayu += "file://fix_builderror_gcc5.patch"