summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-12 18:37:34 +0000
committerGerrit Code Review <gerrit@172.30.200.200>2016-01-13 15:25:07 +0000
commit9dfddcc8bfc9ba13e24c264305f0cdc0194b38b8 (patch)
tree27f3aaedd52ddd95baba4351b5a4191119359913 /meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
parentf44831e7cce334ec6455bf1a87cd82bfcdc08b27 (diff)
QEMU kernel: add and fix fanotify API (SPEC-89)
fanotify API is currently enabled on meta-renesas kernel, and is required by our LTP tests (see mention on https://jira.automotivelinux.org/browse/SPEC-89), but was not available on QEMU kernel. This creates a gap which may break client applications. We also add the patch to fix issue described at https://jira.automotivelinux.org/browse/SPEC-89. Change-Id: Ic201eec7d91553db75f5a5783c47fe1a7d8f7c86 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 24bd38d40..00270faef 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -1,4 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
# Extra configuration options for the QEMU kernel
-SRC_URI += "file://uinput.cfg"
+SRC_URI += "file://0001-fanotify-fix-notification-of-groups-with-inode-mount.patch \
+ file://fanotify.cfg \
+ file://uinput.cfg \
+ "