summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2015-10-21 08:19:02 +0000
committerManuel Bachmann <mbc@iot.bzh>2015-10-22 21:28:17 +0000
commit9201dffde9bf2fefb53c4bee6470c8407bda2b34 (patch)
treea9d89c9a91424d17691ce56164d75e82c3489a3f /meta-agl-bsp/recipes-kernel
parentb9bd3fa51070fe2cce554ccc7bb816cd39ff5dbe (diff)
Provide Wayland FITS, disabled by default
Wayland FITS is a functional integration test suite for Wayland/Weston. It consists in 2 components : a Weston plugin, and a "wfits" binary used to run tests. The tests themselves simulate user interaction with surfaces and windows, using virtual keyboard/mouse/touchscreen drivers. The recipe was recently submitted to the official "meta-openembedded" layer, and can be found here : http://lists.openembedded.org/pipermail/openembedded-devel/ 2015-September/103511.html The package will not be built unless the user explicitly adds "wayland-fits" to his "conf/local.conf" file. QEMU needs the "uinput" driver available on startup, so we always build it, but only install it if the package has been selected. Change-Id: Ib6045007f6c7e1e22b48607a66930ce341c58002 Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/recipes-kernel')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/uinput.cfg3
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend4
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/uinput.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/uinput.cfg
new file mode 100644
index 000000000..7996ef1dd
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/uinput.cfg
@@ -0,0 +1,3 @@
+# Enable the User-level Input driver (required by "wayland-fits")
+CONFIG_INPUT_MISC=y
+CONFIG_INPUT_UINPUT=m
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
new file mode 100644
index 000000000..24bd38d40
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
+
+# Extra configuration options for the QEMU kernel
+SRC_URI += "file://uinput.cfg"