summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2016-11-15 12:27:02 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-11-16 19:11:34 +0000
commitaea4c6d3a46dff5abb4624bd8fa3762d2abb1668 (patch)
tree0fe35ba39ff8f886af100c7634d3c40f64075847 /meta-agl-bsp/recipes-kernel
parentead1bded123556f3aa7d716c4e009d342b891a20 (diff)
Add support for CES 2017 demo hardware
Add kernel config fragments to enable support for the TP-Link TL-W722N USB Wifi adapter on both Turbot and Porter, and RTL2832U DVB USB adapter on Porter. v2 (jsmoeller): Adapt linux-yocto bits and add rpi3 + vayu - moving linux-yocto appends catches all the linux-yocto boards - adding the fragments to the other boards likewise - yet todo: sabre, wandboard v3 (jsmoeller): remove leftover file:// Change-Id: Ic2c3255d9383ccfe8b24d034ef43779d120c5ee1 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/recipes-kernel')
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/ath9k_htc.cfg4
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto/rtl_sdr.cfg4
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend8
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/ath9k_htc.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/ath9k_htc.cfg
new file mode 100644
index 000000000..6f7d49880
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/ath9k_htc.cfg
@@ -0,0 +1,4 @@
+CONFIG_CFG80211=m
+CONFIG_MAC80211=m
+CONFIG_ATH_CARDS=m
+CONFIG_ATH9K_HTC=m
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto/rtl_sdr.cfg b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/rtl_sdr.cfg
new file mode 100644
index 000000000..d4574700a
--- /dev/null
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto/rtl_sdr.cfg
@@ -0,0 +1,4 @@
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_DVB_USB_V2=m
+CONFIG_DVB_USB_RTL28XXU=m
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
index 8b29aacb0..49899a4d9 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -7,6 +7,14 @@ SRC_URI += "file://fanotify.cfg \
file://drm.cfg \
"
+# Enable support for TP-Link TL-W722N USB Wifi adapter
+SRC_URI += " file://ath9k_htc.cfg \
+ "
+
+# Enable support for RTLSDR
+SRC_URI += " file://rtl_sdr.cfg \
+ "
+
# disk drivers for vmdk
SRC_URI_append_qemux86 = " file://vbox-vmware-sata.cfg "
SRC_URI_append_qemux86_64 = " file://vbox-vmware-sata.cfg "