summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-03-30 15:03:03 -0400
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:12:24 +0200
commit8951581150502aeb0be31b2b86fba534abce096b (patch)
treefbc32dd8aa5972762f1657cd82e9fc94bb8074a1 /meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
parentc411b52fb2f502b8c976f005c14abae791e22e92 (diff)
meta-agl-bsp: remove vboxguestdrivers recipe
Remove local vboxguestdrivers recipe as a newer version is available in meta-oe in dunfell. Bug-AGL: SPEC-3302 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I3a7ff17a4bcae2f38a4876aeeed7b5880636ac5b
Diffstat (limited to 'meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils')
-rw-r--r--meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
deleted file mode 100644
index 495601f08..000000000
--- a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
+++ /dev/null
@@ -1,45 +0,0 @@
-## -----------------------------------------------------------------------
-##
-## Copyright 2001-2008 H. Peter Anvin - All Rights Reserved
-##
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation, Inc., 53 Temple Place Ste 330,
-## Boston MA 02111-1307, USA; either version 2 of the License, or
-## (at your option) any later version; incorporated herein by reference.
-##
-## -----------------------------------------------------------------------
-
-INCLUDES = -I. -I../vboxsf -I../vboxsf/include
-MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
- -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
-CFLAGS = ${INCLUDES} ${MOD_DEFS}
-LDFLAGS =
-
-SRCS = mount.vboxsf.c \
- vbsfmount.c
-
-OBJS = $(patsubst %.c,%.o,$(notdir $(SRCS)))
-
-.SUFFIXES: .c .o .i .s .S
-
-
-all: mount.vboxsf
-
-clean:
- -rm -f *.o mount.vboxsf
-
-spotless: clean
- -rm -f *~
-
-mount.vboxsf: $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $^
-
-%.o: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
-%.i: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -E -o $@ $<
-%.s: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -S -o $@ $<
-
--include .*.d *.tmp