summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-10 19:46:16 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-12 15:16:23 +0000
commit8b2bc4509bf25ddb4274cfab8e815a1ba8b116e5 (patch)
tree9fb7b22c83c6af3086504723ad4a0043ef403a3d /meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
parent220daa496a9030dc843c8b5fcc5b96568ea4a3b1 (diff)
Add vboxguestdriver recipe to meta-agl-bsp instead of meta-agl-demo
The drivers will also be needed for the html5 image. Move them to a common layer. Bug-AGL: SPEC-3170 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I9bcfc3b7569b3108442df4e64ec61da0054e4a44
Diffstat (limited to 'meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils')
-rw-r--r--meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
new file mode 100644
index 000000000..495601f08
--- /dev/null
+++ b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
@@ -0,0 +1,45 @@
+## -----------------------------------------------------------------------
+##
+## Copyright 2001-2008 H. Peter Anvin - All Rights Reserved
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, Inc., 53 Temple Place Ste 330,
+## Boston MA 02111-1307, USA; either version 2 of the License, or
+## (at your option) any later version; incorporated herein by reference.
+##
+## -----------------------------------------------------------------------
+
+INCLUDES = -I. -I../vboxsf -I../vboxsf/include
+MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
+ -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
+CFLAGS = ${INCLUDES} ${MOD_DEFS}
+LDFLAGS =
+
+SRCS = mount.vboxsf.c \
+ vbsfmount.c
+
+OBJS = $(patsubst %.c,%.o,$(notdir $(SRCS)))
+
+.SUFFIXES: .c .o .i .s .S
+
+
+all: mount.vboxsf
+
+clean:
+ -rm -f *.o mount.vboxsf
+
+spotless: clean
+ -rm -f *~
+
+mount.vboxsf: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $^
+
+%.o: %.c
+ $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
+%.i: %.c
+ $(CC) $(UMAKEDEPS) $(CFLAGS) -E -o $@ $<
+%.s: %.c
+ $(CC) $(UMAKEDEPS) $(CFLAGS) -S -o $@ $<
+
+-include .*.d *.tmp