summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:32:16 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:32:33 +0200
commitb16f1f6b8bdd7b0cef4aad3a6714798b66d8b0a5 (patch)
tree61c5df69bed7810e988b06434e8efc7ab9071acd /meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
parent40213738bcd84fc542cda3ec6336b0e394b28dcc (diff)
parentc24cdffea9dfa3904fc3ea9da0bc80e5515b078d (diff)
Merge branch 'next'
* next: Temporary workarounds for h3ulcb and bbe [RCAR] use omx-user-module as libomxil provider meta-agl-bsp: dra7xx-evm/beaglebone updates for dunfell meta-agl-bsp: remove obsolete linux-fslc-imx bbappend meta-agl-profile-graphical-qt5: remove Chromium specific bits from SDK meta-agl-profile-graphical: disable memfd usage in weston meta-agl-bsp: update raspberrypi configuration for dunfell meta-agl-{bsp,distro}: update kernel configuration for dunfell meta-agl-profile-core: update psplash for dunfell meta-agl-profile-core: update systemd for dunfell meta-app-framework: set DISTRO_FEATURES_NATIVE meta-agl-profile-core: update bluez5 for dunfell meta-agl-profile-graphical: update weston for dunfell meta-agl-profile-graphical: update wayland-ivi-extension for dunfell meta-agl-profile-graphical: update wayland for dunfell meta-agl-profile-core: update pulseaudio for dunfell meta-security: update to audit 2.8.5 Update distro_features_check usage meta-agl-bsp: remove vboxguestdrivers recipe Declare layer compatibility for dunfell Change-Id: I879ad3040ed6f2fca3f21d189ccce7f1614013b5 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils')
-rw-r--r--meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
deleted file mode 100644
index 495601f08..000000000
--- a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
+++ /dev/null
@@ -1,45 +0,0 @@
-## -----------------------------------------------------------------------
-##
-## Copyright 2001-2008 H. Peter Anvin - All Rights Reserved
-##
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation, Inc., 53 Temple Place Ste 330,
-## Boston MA 02111-1307, USA; either version 2 of the License, or
-## (at your option) any later version; incorporated herein by reference.
-##
-## -----------------------------------------------------------------------
-
-INCLUDES = -I. -I../vboxsf -I../vboxsf/include
-MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
- -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
-CFLAGS = ${INCLUDES} ${MOD_DEFS}
-LDFLAGS =
-
-SRCS = mount.vboxsf.c \
- vbsfmount.c
-
-OBJS = $(patsubst %.c,%.o,$(notdir $(SRCS)))
-
-.SUFFIXES: .c .o .i .s .S
-
-
-all: mount.vboxsf
-
-clean:
- -rm -f *.o mount.vboxsf
-
-spotless: clean
- -rm -f *~
-
-mount.vboxsf: $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $^
-
-%.o: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
-%.i: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -E -o $@ $<
-%.s: %.c
- $(CC) $(UMAKEDEPS) $(CFLAGS) -S -o $@ $<
-
--include .*.d *.tmp