summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-12 09:20:19 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-12 21:50:49 +0000
commit1f94c21af983630e88e4d7230c817e5e570c6055 (patch)
tree10ff1d8b75ecf9777968868d29957295275e09f9 /meta-agl-bsp
parent151ea4141d2e332b706241aebbd3fb5b206b0072 (diff)
weston-ini-conf: Make this track variables correctly for signatures
bitbake does not know to track values that are found and used via getVarFlags() without them being otherwise refernced and tracked in ways that are otherwise caught. Further given that we use multiple levels of varflags here we need to be explicit in their tracking. Add all variables that we use to varflags where they are added to the metadata. Bug-AGL: SPEC-939 Change-Id: I32cf16c4354d733e086c6ea9a845934beff94715 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11255 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend1
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend2
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend2
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend2
5 files changed, 7 insertions, 4 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
index e736dddd2..14f4c2736 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -7,3 +7,4 @@ SCREEN_fbdev[name] = "fbdev"
SCREEN_fbdev[transform] = "270"
WESTONOUTPUT1[agl_screen] = "SCREEN_fbdev"
+do_generate_weston_init[vardeps] += "SCREEN_fbdev"
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston-ini-conf.bbappend
index fb3f1ac32..731578e39 100644
--- a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,8 +1,4 @@
# Select default screen type and orientation
# and only one default output
-# Note when such change is applied it will not be taken due to a Yocto cache error
-# Fix:
-# bitbake weston-ini-conf -c clean ; bitbake weston-ini-conf -c cleansstate
-
WESTONOUTPUT1[agl_screen] = "SCREEN_eGalax"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
index 14b858d45..37383c24d 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -2,3 +2,5 @@
WESTONOUTPUT2[agl_screen] ??= "SCREEN_DSI"
WESTONSECTION[WESTONOUTPUT2] = "output"
+
+do_generate_weston_init[vardeps] += "WESTONOUTPUT2"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index e46b10ef7..661af2b92 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -10,3 +10,5 @@ python() {
if "multimedia" in d.getVar("MACHINE_FEATURES", True).split(" "):
d.setVarFlag("WESTONSECTION", "WESTONV4L2RENDERER", "v4l2-renderer")
}
+
+do_generate_weston_init[vardeps] += "WESTONIVISHELL WESTONV4L2RENDERER"
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
index 7a54dfbe4..4a049482e 100644
--- a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -3,3 +3,5 @@ WESTONOUTPUT2[name] = "LVDS-1"
WESTONOUTPUT2[mode] = "off"
WESTONSECTION[WESTONOUTPUT2] = "output"
+
+do_generate_weston_init[vardeps] += "WESTONOUTPUT2"