summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-07-22 10:53:24 +0900
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2015-07-22 10:53:24 +0900
commit35239b09e077bc578b36729a02771e34b11ecafb (patch)
tree40a6f07016501745ce2c40617738876a625c53de /meta-agl-bsp
parent72201670bd566441ffc0a15270ce2290438632b9 (diff)
Support wayland/weson with GSES on emulated machine, QEMU(x86-64)
To boot weston image on emulated machine QEMU, a new sub-layer `meta-agl-bsp` is added. When bitbake agl-image-weston or agl-image-ivi With this layer, weston GLES can run on QEMU with GLES support. Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/layer.conf10
-rw-r--r--meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend1
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend14
3 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
new file mode 100644
index 000000000..b0010f7c6
--- /dev/null
+++ b/meta-agl-bsp/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "aglbsp"
+BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
+BBFILE_PRIORITY_aglbsp = "7"
diff --git a/meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend b/meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend
new file mode 100644
index 000000000..25615856b
--- /dev/null
+++ b/meta-agl-bsp/recipes-graphics/mesa/mesa_10.%.bbappend
@@ -0,0 +1 @@
+PACKAGECONFIG_append = " gallium gallium-egl gallium-llvm"
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend
new file mode 100644
index 000000000..ce963ea50
--- /dev/null
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston_1.5.0.bbappend
@@ -0,0 +1,14 @@
+RDEPENDS_${PN}_append = " libegl-gallium llvm3.3 "
+
+EXTRA_OECONF_append_vexpressa9 = "\
+ --enable-simple-egl-clients \
+ WESTON_NATIVE_BACKEND=fbdev-backend.so \
+ "
+EXTRA_OECONF_append_qemux86 = "\
+ --enable-simple-egl-clients \
+ WESTON_NATIVE_BACKEND=fbdev-backend.so \
+ "
+EXTRA_OECONF_append_qemux86-64 = "\
+ --enable-simple-egl-clients \
+ WESTON_NATIVE_BACKEND=fbdev-backend.so \
+ "