summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorKarthik Ramanan <a0393906@ti.com>2016-11-10 16:51:08 +0530
committerKarthik Ramanan <a0393906@ti.com>2016-11-10 16:52:14 +0530
commit71b8450f9b954054165711781023b384433c065e (patch)
tree2ff83a439550e5e7130268b0a39bf89d33a670ad /meta-agl-bsp
parent405efca99c1b6cd177391a068fb4f916820ee73e (diff)
dra7xx-evm: add support for graphics acceleration
TI Jacinto 6 has a 3D GPU that can used to accelerate the graphics processing requests. This patch replaces the default graphics drivers and user space libraries only for the dra7xx-evm MACHINE Change-Id: I1a53594f0fa4dc8fabd16f9ce2c765dd32b9e142 Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend7
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension/force-type-conversion.patch13
-rw-r--r--meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend5
3 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend
new file mode 100644
index 000000000..a5a69513a
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -0,0 +1,7 @@
+# Remove GBM support from Mesa
+# TI Platforms provides own GBM library
+
+PACKAGES_remove = "libgbm"
+PACKAGES_remove = "libgbm-dev"
+
+EXTRA_OECONF_remove = "--enable-gbm"
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension/force-type-conversion.patch b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension/force-type-conversion.patch
new file mode 100644
index 000000000..a72aeedf6
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension/force-type-conversion.patch
@@ -0,0 +1,13 @@
+diff --git a/ivi-layermanagement-examples/EGLWLMockNavigation/src/OpenGLES2App.cpp b/ivi-layermanagement-examples/EGLWLMockNavigation/src/OpenGLES2App.cpp
+index 2e65864..e14dbc0 100644
+--- a/ivi-layermanagement-examples/EGLWLMockNavigation/src/OpenGLES2App.cpp
++++ b/ivi-layermanagement-examples/EGLWLMockNavigation/src/OpenGLES2App.cpp
+@@ -244,7 +247,7 @@ bool OpenGLES2App::createEGLContext()
+ m_eglContextStruct.eglSurface = NULL;
+ m_eglContextStruct.eglContext = NULL;
+
+- m_eglContextStruct.eglDisplay = eglGetDisplay(m_wlContextStruct.wlDisplay);
++ m_eglContextStruct.eglDisplay = eglGetDisplay((EGLNativeDisplayType)m_wlContextStruct.wlDisplay);
+ eglstatus = eglGetError();
+ if (!m_eglContextStruct.eglDisplay)
+ {
diff --git a/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
new file mode 100644
index 000000000..e9a57d324
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://force-type-conversion.patch \
+ "