summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-01 12:03:39 -0400
committerScott Murray <scott.murray@konsulko.com>2022-04-03 14:57:56 -0400
commitfa5152323ad2bd3d433aec72c4fec6614656f06d (patch)
tree849403d4f839e20ddc430b165bed1ad297c0344f /meta-agl-bsp
parentdc0c2909547d298981cb58ef4b696ee35f99eb68 (diff)
meta-agl-bsp: Update i.MX8MQ EVK support for kirkstone
Changes: - Rename machine template and related files to use imx8mq-evk instead of imx8mqevk to match meta-freescale change. - Switch to purely using the default "mainline" BSP configuration in meta-freescale for imx8mq-evk as opposed to the tweaking of the "nxp" configuration previously used. The mainline configuration now builds a working image, and this lowers maintenance on our part. - Remove imx8mqevk-viv configuration to build with Vivante GPU driver. NXP have not yet released Weston 10 support, and at this point the etnaviv driver is stable. If a demonstration of support of Vivante is requested in the future (e.g. for other i.MX8 variants that still require it), this can be revisited. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I7e279268463f68978ecd2990927aab6d64e3cbd2
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_imx8mq-evk-common.inc (renamed from meta-agl-bsp/conf/include/agl_imx8mqevk-common.inc)4
-rw-r--r--meta-agl-bsp/conf/include/agl_imx8mq-evk.inc23
-rw-r--r--meta-agl-bsp/conf/include/agl_imx8mqevk-viv.inc1
-rw-r--r--meta-agl-bsp/conf/include/agl_imx8mqevk.inc23
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb2
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch34
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend10
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend10
8 files changed, 26 insertions, 81 deletions
diff --git a/meta-agl-bsp/conf/include/agl_imx8mqevk-common.inc b/meta-agl-bsp/conf/include/agl_imx8mq-evk-common.inc
index f3c4a736e..36493dcbf 100644
--- a/meta-agl-bsp/conf/include/agl_imx8mqevk-common.inc
+++ b/meta-agl-bsp/conf/include/agl_imx8mq-evk-common.inc
@@ -2,10 +2,10 @@ require agl_imx-common.inc
# Force use of the community supported LTS kernel instead of the
# default linux-imx
-IMX_DEFAULT_KERNEL:imx8mqevk = "linux-fslc-imx"
+#IMX_DEFAULT_KERNEL:imx8mq-evk = "linux-fslc-imx"
# For EVKB wifi support
-MACHINE_FEATURES:append = " bcm4356"
+#MACHINE_FEATURES:append = " bcm4356"
# Add helper to drive setting up HCI UART device
MACHINE_EXTRA_RRECOMMENDS:append = " hci-uart-helper"
diff --git a/meta-agl-bsp/conf/include/agl_imx8mq-evk.inc b/meta-agl-bsp/conf/include/agl_imx8mq-evk.inc
new file mode 100644
index 000000000..d04ee41a7
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_imx8mq-evk.inc
@@ -0,0 +1,23 @@
+include agl_imx8mq-evk-common.inc
+
+# NOTE: currently not using IMX_DEFAULT_BSP = "mainline", as it
+# requires more changes than this approach of disabling
+# Vivante.
+
+# Add our own over-ride for use in a few recipes where there is
+# conflicting Vivante vs etnaviv configuration.
+#MACHINEOVERRIDES .= ":etnaviv"
+
+# Knock out Vivante overrides
+#MACHINEOVERRIDES_EXTENDER:mx8mq:forcevariable = ""
+#PREFERRED_VERSION_weston_mx8 = "8.0.0"
+#PREFERRED_VERSION_wayland-protocols_mx8 = "1.20"
+#PREFERRED_VERSION_libdrm_mx8 = "2.4.101"
+
+#CORE_IMAGE_EXTRA_INSTALL += "libdrm-etnaviv"
+
+#PREFERRED_VERSION_gstreamer1.0_mx8 = "1.16.3"
+#PREFERRED_VERSION_gstreamer1.0-plugins-base_mx8 = "1.16.3"
+#PREFERRED_VERSION_gstreamer1.0-plugins-good_mx8 = "1.16.3"
+#PREFERRED_VERSION_gstreamer1.0-plugins-bad_mx8 = "1.16.3"
+#PREFERRED_VERSION_gstreamer1.0-plugins-ugly_mx8 = "1.16.3"
diff --git a/meta-agl-bsp/conf/include/agl_imx8mqevk-viv.inc b/meta-agl-bsp/conf/include/agl_imx8mqevk-viv.inc
deleted file mode 100644
index 8227f5c06..000000000
--- a/meta-agl-bsp/conf/include/agl_imx8mqevk-viv.inc
+++ /dev/null
@@ -1 +0,0 @@
-include agl_imx8mqevk-common.inc
diff --git a/meta-agl-bsp/conf/include/agl_imx8mqevk.inc b/meta-agl-bsp/conf/include/agl_imx8mqevk.inc
deleted file mode 100644
index 6801722be..000000000
--- a/meta-agl-bsp/conf/include/agl_imx8mqevk.inc
+++ /dev/null
@@ -1,23 +0,0 @@
-include agl_imx8mqevk-common.inc
-
-# NOTE: currently not using IMX_DEFAULT_BSP = "mainline", as it
-# requires more changes than this approach of disabling
-# Vivante.
-
-# Add our own over-ride for use in a few recipes where there is
-# conflicting Vivante vs etnaviv configuration.
-MACHINEOVERRIDES .= ":etnaviv"
-
-# Knock out Vivante overrides
-MACHINEOVERRIDES_EXTENDER:mx8mq:forcevariable = ""
-PREFERRED_VERSION_weston_mx8 = "8.0.0"
-PREFERRED_VERSION_wayland-protocols_mx8 = "1.20"
-PREFERRED_VERSION_libdrm_mx8 = "2.4.101"
-
-CORE_IMAGE_EXTRA_INSTALL += "libdrm-etnaviv"
-
-PREFERRED_VERSION_gstreamer1.0_mx8 = "1.16.3"
-PREFERRED_VERSION_gstreamer1.0-plugins-base_mx8 = "1.16.3"
-PREFERRED_VERSION_gstreamer1.0-plugins-good_mx8 = "1.16.3"
-PREFERRED_VERSION_gstreamer1.0-plugins-bad_mx8 = "1.16.3"
-PREFERRED_VERSION_gstreamer1.0-plugins-ugly_mx8 = "1.16.3"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
index 1a9c6bb4e..798fcebe6 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
@@ -8,7 +8,7 @@ SRC_URI = "file://hci-uart-helper.service \
file://hci-uart-helper.sh \
"
-COMPATIBLE_MACHINE = "imx8mqevk"
+COMPATIBLE_MACHINE = "imx8mq-evk"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch
deleted file mode 100644
index 7f7ab9124..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/files/0001-kmsro-add-imx-dcss.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Add i.MX8MQ DCSS kmsro support
-
-Add required dummy entry for NXP's i.MX8MQ DCSS display controller DRM
-driver to the kmsro configuration so that the loader will not think it
-is a GPU.
-
-Upstream-Status: pending
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
----
-
-diff --git a/src/gallium/targets/dri/meson.build b/src/gallium/targets/dri/meson.build
-index ae25a21..17379c7 100644
---- a/src/gallium/targets/dri/meson.build
-+++ b/src/gallium/targets/dri/meson.build
-@@ -72,6 +72,7 @@ foreach d : [[with_gallium_kmsro, [
- 'hx8357d_dri.so',
- 'ili9225_dri.so',
- 'ili9341_dri.so',
-+ 'imx-dcss_dri.so',
- 'imx-drm_dri.so',
- 'ingenic-drm_dri.so',
- 'mcde_dri.so',
-diff --git a/src/gallium/targets/dri/target.c b/src/gallium/targets/dri/target.c
-index f71f690..41c5c75 100644
---- a/src/gallium/targets/dri/target.c
-+++ b/src/gallium/targets/dri/target.c
-@@ -97,6 +97,7 @@ DEFINE_LOADER_DRM_ENTRYPOINT(exynos)
- DEFINE_LOADER_DRM_ENTRYPOINT(hx8357d)
- DEFINE_LOADER_DRM_ENTRYPOINT(ili9225)
- DEFINE_LOADER_DRM_ENTRYPOINT(ili9341)
-+DEFINE_LOADER_DRM_ENTRYPOINT(imx_dcss)
- DEFINE_LOADER_DRM_ENTRYPOINT(imx_drm)
- DEFINE_LOADER_DRM_ENTRYPOINT(ingenic_drm)
- DEFINE_LOADER_DRM_ENTRYPOINT(mcde)
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend
deleted file mode 100644
index e7633f215..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/mesa/mesa_%.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://0001-kmsro-add-imx-dcss.patch"
-
-# These over-rides should use "use-mainline-bsp" instead when that
-# becomes more workable for i.MX8 in upstream meta-freescale.
-
-USE_OSMESA_ONLY:etnaviv = "no"
-
-PACKAGECONFIG:append:etnaviv = " gallium etnaviv kmsro"
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
deleted file mode 100644
index 270d8e8f5..000000000
--- a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
+++ /dev/null
@@ -1,10 +0,0 @@
-# Work around PACKAGECONFIG:remove of "x11 wayland" added to the recipe
-# in meta-freescale commit 5a5c5dd. This can be removed once the issue
-# has been resolved by a revert of that breakage upstream.
-# What is done below is effectively a disabling of the "wayland"
-# PACKAGECONFIG option and then open coding what its effects would
-# normally be, since the _remove prevents specifying it in the usual way.
-PACKAGECONFIG[wayland] = ""
-DEPENDS:append = " virtual/egl virtual/libgles2"
-PACKAGECONFIG_CONFARGS:append = " -Dbackend-wayland=true"
-