summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
diff options
context:
space:
mode:
authorAnusha Gugale <external.agogale@jp.adit-jv.com>2020-12-17 12:57:48 +0530
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-12 20:41:47 +0000
commite0413d70c66c98e5ec7fa30893b3ecd6b5141ff4 (patch)
treef4e68acb21fddd29daea9232b432b13c466b38e2 /meta-agl-core/recipes-graphics/rba/librba_1.0.bb
parent8395c5513a6fd133d47a92f88f92ebeacf8183e5 (diff)
meta-agl-core: add recipe for librba and rba-config
- Required for agl-compositor rba policy - RBAModel.json will be install using rba-config recipe file Bug-AGL: SPEC-3738 Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com> Change-Id: I05244dcceb8f0ba56865ce1edf1563b90bdfbae3 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25821 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/recipes-graphics/rba/librba_1.0.bb')
-rw-r--r--meta-agl-core/recipes-graphics/rba/librba_1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/rba/librba_1.0.bb b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
new file mode 100644
index 000000000..450684f83
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "RBA"
+DESCRIPTION = "Rule Based Arbitrator decides which of the content to display \
+when a large number of contents to be displayed on the cockpit display device \
+(CID, meter, HUD, etc.) occur simultaneously under a certain rule (arbitration)"
+
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=13afa517927767fe9b7a65818a02bd8f"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/rba;protocol=https;branch=master"
+SRCREV = "2cfe2c611be63ae4541abf4e13cfecff0f008f25"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+FILES_${PN} = "${libdir}/"
+FILES_${PN}-dev = "${libdir}/pkgconfig/librba.pc \
+ ${includedir}/ \
+ "
+INSANE_SKIP_${PN} += "dev-so"
+INSANE_SKIP_${PN}-dev += "dev-elf"