summaryrefslogtreecommitdiffstats
path: root/meta-agl-core
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2023-11-14 12:21:48 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-16 14:47:55 +0000
commit067b29a6a3af5d497a0294aedb56cb43c5a1f315 (patch)
treeaabbe57dc9d90ca4b518622690c5ab64af20c0df /meta-agl-core
parent8adcf79acecd3592ac6ff969b00d7cbf805ff941 (diff)
recipes-graphics/wayland/agl-compositor_git.bb: Bump SRCREV
This SRC_REV bump updates the gRPC proxy API to address some start-up issues we're seeing when switching the qt homescreen shell client to using the start-up + activation procedure rather than relying on the wayland protocol to do that. A smaller fix for restarting the compositor, as well as functionality to dynamically move windows with it and scale windows was added in this update. The recipe changes does include a version bump for the compositor as well, making it easier to track down the compositor version. In more detail, the following changes have been added since the previous update: - bdc551314dc5 meson.build: Bump version to 0.0.22 - be197db866b8 grpc-proxy: Use smaller waiting time - 73e82a6f346d grpc-proxy: Start the gRPC server and waiting thread much sooner - 53b470c60986 grpc-proxy: Fix missing args LOG() - 0d2e33ded529 grpc-proxy/main-grpc: Don't fall trough assuming we have a wl_display - 994d8a30b27f grpc-proxy: Don't attempt to connect if there's no compositor running - d8e72099ecbc grpc-proxy: Terminate thread when we're exiting - ca537df2c529 grpc-proxy: Add dynamic scale of floating windows - 2edba91d3eab grpc-proxy: Add dynamic floating window movement Change-Id: Ic07b11e6334f14f60a1d71e48347a3d66f07b823 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29405 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
index a06f85ea4..393513320 100644
--- a/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
@@ -11,11 +11,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fac6abe0003c4d142ff8fa1f18316df0"
DEPENDS = "wayland wayland-protocols wayland-native weston"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "a68408367cf5e254d981e1d43ba261b9aade6166"
+SRCREV = "bdc551314dc5511be31550b8c2e06641b9a94639"
AGL_BRANCH:aglnext = "next"
SRCREV:aglnext = "${AUTOREV}"
-PV = "0.0.10+git${SRCPV}"
+AGL_COMPOSITOR_VERSION = "0.0.22"
+
+PV = "${AGL_COMPOSITOR_VERSION}+git${SRCPV}"
S = "${WORKDIR}/git"
PACKAGECONFIG ?= ""
@@ -36,7 +38,7 @@ FILES:${PN} = " \
${bindir}/agl-compositor \
${bindir}/agl-screenshooter \
${libdir}/agl-compositor/libexec_compositor.so.0 \
- ${libdir}/agl-compositor/libexec_compositor.so.0.0.21 \
+ ${libdir}/agl-compositor/libexec_compositor.so.${AGL_COMPOSITOR_VERSION} \
"
FILES:agl-shell-grpc-server = " \