summaryrefslogtreecommitdiffstats
path: root/meta-agl-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-23 16:28:01 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-29 15:23:32 -0400
commit09ad500c71a9bbd003c21654bf8fc535d65117a6 (patch)
tree65db7660f1388e70c6459e1d0f84222cd5023497 /meta-agl-core
parent47bf86a3e5d9015f504de4d64942bd17a643b4e6 (diff)
meta-agl-core: update weston-ini-conf
Update weston-ini-conf recipe to handle weston 9.0 in poky master. The changes are to handle the flip of the meaning of 90 and 270 degree rotations in the transform option in weston.ini, and the rename of its values to "rotate-X" instead of just the number of degrees. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2bb316a195f7eb3733ff757a565535317db1da08
Diffstat (limited to 'meta-agl-core')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb5
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270.cfg2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-90.cfg2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-180.cfg2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-270.cfg2
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-90.cfg4
8 files changed, 14 insertions, 9 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index c635d7b2f..c04ff6568 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -12,6 +12,7 @@ SRC_URI = " \
file://remote-output.cfg \
file://transmitter-output.cfg.in \
file://virtual-0.cfg \
+ file://virtual-90.cfg \
file://virtual-180.cfg \
file://virtual-270.cfg \
"
@@ -21,7 +22,7 @@ S = "${WORKDIR}"
inherit update-alternatives
# Default primary display/orientation fragment
-WESTON_DISPLAYS ?= "hdmi-a-1-270"
+WESTON_DISPLAYS ?= "hdmi-a-1-90"
# Configuration fragments to use in weston.ini.*
# Note that some may be replaced/removed when building the landscape
@@ -63,7 +64,7 @@ do_compile() {
if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then
F="hdmi-a-1-0"
INVF="hdmi-a-1-180"
- elif echo $F | grep '^virtual-270$'; then
+ elif echo $F | grep '^virtual-90$'; then
F="virtual-0"
INVF="virtual-180"
fi
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
index c4cf6c152..d441d6577 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -8,5 +8,5 @@ WESTON_DISPLAYS:append = "${@bb.utils.contains("AGL_FEATURES", "waltham-remoting
# For virtual machines and intel-corei7-64 we want to support both the HDMI-A-1
# and Virtual-1 outputs. This allows us to run virtual images on real hardware
# and vice versa.
-WESTON_DISPLAYS:append:qemuall = " virtual-270"
-WESTON_DISPLAYS:append:intel-corei7-64 = " virtual-270"
+WESTON_DISPLAYS:append:qemuall = " virtual-90"
+WESTON_DISPLAYS:append:intel-corei7-64 = " virtual-90"
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg
index 7648c779b..b6f4329ef 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-180.cfg
@@ -1,4 +1,4 @@
# A display is connected to HDMI-A-1
[output]
name=HDMI-A-1
-transform=180
+transform=rotate-180
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270.cfg
index dffc2b6dd..187f2c7bd 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-270.cfg
@@ -3,4 +3,4 @@
# of the GeChic display or the Dell display.
[output]
name=HDMI-A-1
-transform=270
+transform=rotate-270
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-90.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-90.cfg
index 88a692a1b..5ee9c1904 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-90.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/hdmi-a-1-90.cfg
@@ -3,4 +3,4 @@
# display used in some instances.
[output]
name=HDMI-A-1
-transform=90
+transform=rotate-90
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-180.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-180.cfg
index 34a741d40..0363b6339 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-180.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-180.cfg
@@ -1,4 +1,4 @@
[output]
name=Virtual-1
mode=1920x1080
-transform=180
+transform=rotate-180
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-270.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-270.cfg
index 0e5b536a6..c3f72f495 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-270.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-270.cfg
@@ -1,4 +1,4 @@
[output]
name=Virtual-1
mode=1920x1080
-transform=270
+transform=rotate-270
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-90.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-90.cfg
new file mode 100644
index 000000000..96d9c3a04
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/virtual-90.cfg
@@ -0,0 +1,4 @@
+[output]
+name=Virtual-1
+mode=1920x1080
+transform=rotate-90