summaryrefslogtreecommitdiffstats
path: root/meta-agl-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-10-30 17:21:46 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-11-05 17:38:46 +0000
commitdb2efee31d3c871a1e5f4fe665e0f3daa01a27f8 (patch)
treeed0481e8fa6a6f70f058232e92b940793cc50115 /meta-agl-core
parenta3bca90049cb704e83f62c81d7d328fd4b15ce8c (diff)
agl-users: factor out reusable include file
Refactor the recipe to put the actual useradd configuration into an include file. This will allow other recipes that need to use the agl-driver user for file ownership to pull that in as opposed to duplicating the configuration and risking mismatches. Bug-AGL: SPEC-4952 Change-Id: Ica16a13a3750722c6d22b14944898f7b289e4bbe Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29340 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core')
-rw-r--r--meta-agl-core/recipes-config/agl-users/agl-users.inc14
-rw-r--r--meta-agl-core/recipes-config/agl-users/agl-users_1.0.bb15
2 files changed, 16 insertions, 13 deletions
diff --git a/meta-agl-core/recipes-config/agl-users/agl-users.inc b/meta-agl-core/recipes-config/agl-users/agl-users.inc
new file mode 100644
index 000000000..428af3806
--- /dev/null
+++ b/meta-agl-core/recipes-config/agl-users/agl-users.inc
@@ -0,0 +1,14 @@
+inherit useradd
+
+USERADD_PACKAGES = "${PN}"
+USERADDEXTENSION = "useradd-staticids"
+
+GROUPADD_PARAM:${PN} = "\
+ --system video ; \
+ --system pipewire ; \
+ -g 1001 agl-driver ; \
+"
+
+USERADD_PARAM:${PN} = "\
+ -g 1001 -u 1001 -G video,pipewire -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
+"
diff --git a/meta-agl-core/recipes-config/agl-users/agl-users_1.0.bb b/meta-agl-core/recipes-config/agl-users/agl-users_1.0.bb
index eda477f7a..18f25e4be 100644
--- a/meta-agl-core/recipes-config/agl-users/agl-users_1.0.bb
+++ b/meta-agl-core/recipes-config/agl-users/agl-users_1.0.bb
@@ -2,19 +2,8 @@ SUMMARY = "AGL Users"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-inherit allarch useradd
+inherit allarch
-USERADD_PACKAGES = "${PN}"
-USERADDEXTENSION = "useradd-staticids"
-
-GROUPADD_PARAM:${PN} = "\
- --system video ; \
- --system pipewire ; \
- -g 1001 agl-driver ; \
-"
-
-USERADD_PARAM:${PN} = "\
- -g 1001 -u 1001 -G video,pipewire -o -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
-"
+require agl-users.inc
ALLOW_EMPTY:${PN} = "1"