summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-11-12 22:22:57 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-11-19 16:34:09 +0000
commit0bbd4c12cb6c64596607be83884e2352e7c91cab (patch)
tree645b42fda06b87b1b788b20a8bd25323789fbd65 /meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
parent01262cab6e495f9d0140b40d866465d1539c1043 (diff)
agl-service-hvac: rework configuration file packaging
Move agl-service-hvac hvac.json configuration file install into its own recipe so that just it will be machine-specific, and replace m3ulcb-specific agl-service-hvac bbappend with a more generic do_install_append_ulcb in the new agl-service-hvac-conf recipe. Bug-AGL: SPEC-2949 Change-Id: Iabdfa2c204017a30bf82bed3eb6debbd3eb0be9c Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb')
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
new file mode 100644
index 000000000..e4dccbf3d
--- /dev/null
+++ b/meta-agl-profile-core/recipes-apis/agl-service-hvac/agl-service-hvac-conf_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "HVAC Service Binding Configuration"
+DESCRIPTION = "AGL HVAC Service Binding Configuration"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-hvac"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ install -D -m 644 ${S}/hvac.json ${D}${sysconfdir}/hvac.json
+}
+
+do_install_append_ulcb() {
+ sed -i -e "s#vcan0#sllin0#g" ${D}${sysconfdir}/hvac.json
+}
+