summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-03-02 22:31:10 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-03-07 01:20:27 +0000
commitc0db05cf193aada32cc61e52e7d820375478a8d5 (patch)
tree20bc51b8308cc1b87bd8496d92950dc2601122e8 /meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
parentfd71c729ba03279cb9ad3a03290336afcae20bc0 (diff)
agl-login-manager: Move to meta-agl-profile-core
Move agl-login-manager recipe to meta-agl-profile-core layer from meta-agl-profile-graphical to make it available for non-graphical profiles, e.g. the telematics profile. Change-Id: Ic3c875bb499f781ea2c0d48558cba6cf4cc704c3 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb')
-rw-r--r--meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
new file mode 100644
index 000000000..49efce796
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "AGL Login manager"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+LOGIN_USER ??="1001 1002"
+
+RDEPENDS_${PN} += "af-main"
+
+do_install_append() {
+
+ install -d ${D}${systemd_system_unitdir}/multi-user.target.wants/
+
+ for AGL_USER in ${LOGIN_USER};do
+ ln -s ../afm-user-session@.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-user-session@${AGL_USER}.service
+ done
+}
+
+FILES_${PN} += "${systemd_system_unitdir}"