summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-02-14 01:23:38 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-02-18 11:28:33 +0000
commitd06dcbb08fccbb92ce8c79c39db7ea20e2bd2e6c (patch)
tree2f29772cc3d5f302eb0eaea16f22cc0366a921cd /meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch
parentee17410d05874c0b9ca6e29e1c16dfa753de9146 (diff)
recipes-connectivity: connman: upgrade to 1.36
Backport from openembedded-core layer because needs the respective WiFi improvements: Fix issue with WiFi background scanning handling. Fix issue with WiFi disconnect+connect race condition. Fix issue with WiFi scanning and tethering operation. Fix issue with WiFi security change handling. Fix issue with missing signal for WPS changes. Bug-AGL: SPEC-1165 Change-Id: Ibf2b2039b39c2b7096f9549d569b83e86fa759bc Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
Diffstat (limited to 'meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch b/meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch
new file mode 100644
index 000000000..e96e38bcf
--- /dev/null
+++ b/meta-agl-profile-core/recipes-connectivity/connman/connman/no-version-scripts.patch
@@ -0,0 +1,27 @@
+With binutils 2.27 on at least MIPS, connmand will crash on startup. This
+appears to be due to the symbol visibilty scripts hiding symbols that stdio
+looks up at runtime, resulting in it segfaulting.
+
+This certainly appears to be a bug in binutils 2.27 although the problem has
+been known about for some time:
+
+https://sourceware.org/bugzilla/show_bug.cgi?id=17908
+
+As the version scripts are only used to hide symbols from plugins we can safely
+remove the scripts to work around the problem until binutils is fixed.
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.am b/Makefile.am
+index d70725c..76ae432 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -132,2 +132 @@ src_connmand_LDADD = gdbus/libgdbus-internal.la $(builtin_libadd) \
+-src_connmand_LDFLAGS = -Wl,--export-dynamic \
+- -Wl,--version-script=$(srcdir)/src/connman.ver
++src_connmand_LDFLAGS = -Wl,--export-dynamic
+@@ -166,2 +165 @@ vpn_connman_vpnd_LDADD = gdbus/libgdbus-internal.la $(builtin_vpn_libadd) \
+-vpn_connman_vpnd_LDFLAGS = -Wl,--export-dynamic \
+- -Wl,--version-script=$(srcdir)/vpn/vpn.ver
++vpn_connman_vpnd_LDFLAGS = -Wl,--export-dynamic