summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-connectivity/neardal
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-08 11:12:45 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:59:52 +0000
commit1c3c06842ac1b9c089d0a08e91c60f44e4844fac (patch)
tree21e97368be8f78a3e76b66dfda24c1d5e774519f /meta-agl-profile-core/recipes-connectivity/neardal
parentc1e048fc05542d859115990312e0753ce2dea72e (diff)
SPEC-3723: restructure meta-agl
Goal is to reach a minimal meta-agl-core as base for IVI and IC work at the same time. Trim dependencies and move most 'demo' related recipes to meta-agl-demo. v2: changed to bbapend + .inc , added description v3: testbuild of all images v4: restore -test packagegroup and -qa images, compare manifests and adapt packagegroups. v5: rebased v6: merged meta-agl-distro into meta-agl-core, due to dependency on meta-oe, moved -test packagegroup and -qa images to own layer meta-agl-core-test v7: Fixed comments from Paul Barker v8: Update the markdown files v9: restore wayland/weston/agl-compositor recipes/appends, reworked to move app f/w specific changes to bbappends in meta-app-framework and only demo specific weston-init changes to meta-agl-demo v10: fix s/agldemo/aglcore/ missed in weston-init.bbappend Description: This patch is part 1 out of 2 large patches that implement the layer rework discussed during the previous workshop. Essentially meta-agl-core is the small but versatile new core layer of AGL serving as basis for the work done by the IC and IVI EGs. All demo related work is moved to meta-agl-demo in the 2nd patchset. This should be applied together as atomic change. The resulting meta-agl/* follows these guidelines: - only bsp adaptations in meta-agl-bsp - remove the agl-profile-* layers for simplicity -- the packagegroup-agl(-profile)-graphical and so on have been kept in meta-agl-demo - meta-agl-profile-core is now meta-agl-core - meta-agl-core does pass yocto-check-layer -- therefore use the bbappend + conditional + .inc file construct found in meta-virtualization - meta-agl/meta-security has been merged into meta-agl/meta-app-framework - meta-netboot does pass yocto-check-layer - meta-pipewire does pass yocto-check-layer Migration: All packagegroups are preserved but they're now enabled by 'agl-demo'. Bug-AGL: SPEC-3723 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia6c6e5e6ce2b4ffa69ea94959cdc57c310ba7c53 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25769
Diffstat (limited to 'meta-agl-profile-core/recipes-connectivity/neardal')
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal.inc22
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal/0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch27
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch58
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal/ncl.patch25
-rw-r--r--meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb10
5 files changed, 0 insertions, 142 deletions
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal.inc b/meta-agl-profile-core/recipes-connectivity/neardal/neardal.inc
deleted file mode 100644
index 3bb6b24ec..000000000
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal.inc
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Neard Abstraction Library (NeardAL)"
-
-DESCRIPTION = "NeardAL is a library that provides a simple C API \
-to exchange data with NFC daemon (Neard)."
-
-HOMEPAGE = "https://github.com/connectivity/neardal"
-SECTION = "libs"
-LICENSE = "LGPLv2"
-
-DEPENDS = "glib-2.0 readline glib-2.0-native"
-
-LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
- file://lib/neardal.h;endline=20;md5=a53e93aea9357387078ed217565c0a99"
-
-inherit autotools pkgconfig
-
-PACKAGES =+ "${PN}-tools ${PN}-tools-dbg"
-
-FILES_${PN}-tools = "${libexecdir}/ncl"
-FILES_${PN}-tools-dbg += "${libexecdir}/.debug"
-
-RDEPENDS_${PN}-tools = "bash"
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch b/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch
deleted file mode 100644
index 596fe0579..000000000
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 795308b2452ee617da4096914b53ba3a1142e3db Mon Sep 17 00:00:00 2001
-From: Matt Ranostay <matt.ranostay@konsulko.com>
-Date: Fri, 6 Jul 2018 17:19:09 -0700
-Subject: [PATCH] neardal: ncl: fix segfault on help page being displayed
-
-LISTCMD_NAME is declared as a const char due to being defined in a
-macro so g_strdup it to stop proceeding operations from segfaulting.
-
-Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-
----
- ncl/ncl.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ncl/ncl.c b/ncl/ncl.c
-index 590d13b..f4165b7 100644
---- a/ncl/ncl.c
-+++ b/ncl/ncl.c
-@@ -329,7 +329,7 @@ int main(int argc, char *argv[])
- g_io_channel_unref(gNclCtx.channel);
-
- if (show_help)
-- ncl_exec(LISTCMD_NAME);
-+ ncl_exec(g_strdup(LISTCMD_NAME));
-
- rl_callback_handler_install(NCL_PROMPT, ncl_parse_line);
-
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch b/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch
deleted file mode 100644
index d40d9a4fe..000000000
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/0002-neardal-lib-fix-memory-corruption.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From ee6267f357b3d158f0a0e88460782e8b9d44274a Mon Sep 17 00:00:00 2001
-From: Raquel Medina <raquel.medina@konsulko.com>
-Date: Fri, 4 Jan 2019 07:43:03 -0500
-Subject: [PATCH] neardal: lib: fix memory corruption
-
- The current commit fixes an invalid memory access
- which manifests as a random segfault when executing
- continuous tag read operations.
-
- The corruption happens when releasing the memory allocated to a
- record: in the time between the memory being g_free'd and the
- subsequent memset operation, the memory could have been reused by
- some other process. And since memory allocation depends on
- system-wide factors, it makes this bug hard to track.
-
- Tested using ACR122U reader and NTAG213
- tags on Automotive Grade Linux (flounder,
- guppy and master branches)
-
-Signed-off-by: Raquel Medina <raquel.medina@konsulko.com>
----
- lib/neardal_record.c | 1 -
- lib/neardal_tools.c | 5 ++++-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/lib/neardal_record.c b/lib/neardal_record.c
-index 669012c..cfed5e8 100644
---- a/lib/neardal_record.c
-+++ b/lib/neardal_record.c
-@@ -31,7 +31,6 @@ void neardal_record_free(neardal_record *r)
- {
- g_return_if_fail(r);
- neardal_g_strfreev((void **) r, &r->uriObjSize);
-- memset(r, 0, sizeof(*r));
- }
-
- void neardal_free_record(neardal_record *record) \
-diff --git a/lib/neardal_tools.c b/lib/neardal_tools.c
-index f0d6157..f307df6 100644
---- a/lib/neardal_tools.c
-+++ b/lib/neardal_tools.c
-@@ -32,9 +32,12 @@
- void neardal_g_strfreev(void **array, void *end)
- {
- void **p = array;
-- for (; (void *) p < end; p++)
-+ for (; (void *) p < end; p++) {
- g_free(*p);
-+ *p = NULL;
-+ }
- g_free(array);
-+ array = NULL;
- }
-
- void neardal_g_variant_add_parsed(GVariant **v, const char *format, ...)
---
-2.17.1
-
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/ncl.patch b/meta-agl-profile-core/recipes-connectivity/neardal/neardal/ncl.patch
deleted file mode 100644
index baef6ccaa..000000000
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal/ncl.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From eab402bae42c3ea5caa8d540b6702d39e56c84c1 Mon Sep 17 00:00:00 2001
-From: Oleg Zhurakivskyy <oleg.zhurakivskyy@intel.com>
-Date: Tue, 10 Feb 2015 12:58:39 +0200
-Subject: [PATCH] build: Install ncl
-
-Signed-off-by: Oleg Zhurakivskyy <oleg.zhurakivskyy@intel.com>
----
- ncl/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/ncl/Makefile.am b/ncl/Makefile.am
-index beda75b..c06742f 100644
---- a/ncl/Makefile.am
-+++ b/ncl/Makefile.am
-@@ -1,6 +1,6 @@
- AM_CPPFLAGS = @gio_CFLAGS@ -I$(top_builddir)/lib -I$(top_srcdir)/lib
-
--noinst_PROGRAMS=ncl
-+libexec_PROGRAMS = ncl
-
- ncl_SOURCES = \
- $(srcdir)/ncl.c $(srcdir)/ncl.h \
---
-2.1.0
-
diff --git a/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb b/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb
deleted file mode 100644
index f8634c468..000000000
--- a/meta-agl-profile-core/recipes-connectivity/neardal/neardal_0.14.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require neardal.inc
-
-SRC_URI = "git://github.com/connectivity/neardal.git;protocol=https \
- file://ncl.patch \
- file://0001-neardal-ncl-fix-segfault-on-help-page-being-displaye.patch \
- file://0002-neardal-lib-fix-memory-corruption.patch \
- "
-SRCREV = "fe0fa79c94e9a0f1c2cfa1f58b3acc9bdc7d5e13"
-
-S = "${WORKDIR}/git"