summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-02 16:24:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-03 16:02:41 +0000
commit72e884bc11ac69de9491620fa8b32cee928e05ba (patch)
treea0568d93737ae9ce274a59685c46cfdd266ae2f8 /meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
parent6976dc76c4bfaed7ec519c8d0d8c9d39396c9469 (diff)
meta-agl-profile-core: add pyagl to agl-devel images
Changes: - Add recipe for pyagl, and add it as a dependency of packagegroup-agl-core-devel. - Add recipes for pyagl dependencies python3-asyncssh, python3-pytest-dependency, and python3-pytest-reverse. The intent is to get these into upstream meta-python so these local copies can be dropped when they're available from there. Bug-AGL: SPEC-3562 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I876ef2fffbe8724aadb23170e1ed196f05132f89 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25176 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb')
-rw-r--r--meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb b/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
new file mode 100644
index 000000000..ab7e8afa9
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/python/python3-asyncssh_2.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "\
+AsyncSSH is a Python package which provides an asynchronous client and \
+server implementation of the SSHv2 protocol on top of the Python \
+asyncio framework."
+HOMEPAGE = "https://github.com/ronf/asyncssh"
+LICENSE = "EPL-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"
+
+SRC_URI[sha256sum] = "44bda34c7123f00c3df95d24e2dc8d43c4d17b456fbb8c434ef4f4a7ebb5265e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-asyncio ${PYTHON_PN}-cryptography"
+
+BBCLASSEXTEND = "native"