summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-09-02 16:24:39 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-09-03 16:02:41 +0000
commit72e884bc11ac69de9491620fa8b32cee928e05ba (patch)
treea0568d93737ae9ce274a59685c46cfdd266ae2f8 /meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
parent6976dc76c4bfaed7ec519c8d0d8c9d39396c9469 (diff)
meta-agl-profile-core: add pyagl to agl-devel images
Changes: - Add recipe for pyagl, and add it as a dependency of packagegroup-agl-core-devel. - Add recipes for pyagl dependencies python3-asyncssh, python3-pytest-dependency, and python3-pytest-reverse. The intent is to get these into upstream meta-python so these local copies can be dropped when they're available from there. Bug-AGL: SPEC-3562 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I876ef2fffbe8724aadb23170e1ed196f05132f89 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25176 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb')
-rw-r--r--meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
new file mode 100644
index 000000000..5ff2d4ecf
--- /dev/null
+++ b/meta-agl-profile-core/recipes-devtools/python/python3-pytest-dependency_0.5.1.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "pytest-dependency manages dependencies of tests."
+HOMEPAGE = "https://github.com/RKrahl/pytest-dependency"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=35b9938ae48d25e6b8306232e98463dd"
+
+SRC_URI[sha256sum] = "c2a892906192663f85030a6ab91304e508e546cddfe557d692d61ec57a1d946b"
+
+inherit pypi setuptools3
+
+DEPENDS += "${PYTHON_PN}-pytest-native"
+
+BBCLASSEXTEND = "native"